Bug 1335382 - yum update: HTTPS Error 404 - Not Found -- /pulp/repos missing in URL
Summary: yum update: HTTPS Error 404 - Not Found -- /pulp/repos missing in URL
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Candlepin
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Barnaby Court
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On: 1413161
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-12 06:55 UTC by Sebastian Hetze
Modified: 2017-01-16 15:36 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1413161 (view as bug list)
Environment:
Last Closed: 2017-01-16 15:36:06 UTC
Target Upstream Version:


Attachments (Terms of Use)
messages from subscription-manager re-registration (3.61 KB, text/plain)
2016-05-22 13:58 UTC, Sebastian Hetze
no flags Details
rhsm.log from subscription-manager re-registration (26.54 KB, text/plain)
2016-05-22 13:59 UTC, Sebastian Hetze
no flags Details
redhat.repo with missing /pulp/repos in URL (1.22 KB, text/plain)
2016-05-22 14:04 UTC, Sebastian Hetze
no flags Details
rhsm.conf for client with missing /pulp/repos in the URL (1.61 KB, text/plain)
2016-06-16 11:59 UTC, Sebastian Hetze
no flags Details

Description Sebastian Hetze 2016-05-12 06:55:56 UTC
Description of problem:

After successful registration of a client to Satellite-6.2, all attempts to access the Satellite repos fail with HTTPS Error 404 - Not Found

More detailed:
https://sat62.example.com/ACME/development/rhel7_base/content/dist/rhel/server/7/7Server/x86_64/os/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found

It works when changing the URL to 
https://sat62.example.com/pulp/repos/ACME/development/rhel7_base/content/dist/rhel/server/7/7Server/x86_64/os/repodata/repomd.xml


Version-Release number of selected component (if applicable):
Satellite 6.2 Beta

How reproducible:
Always

Steps to Reproduce:
1. Install Sat6.2 Beta
2. Register Client
3. yum update

Actual results:
[Errno 14] HTTPS Error 404 - Not Found

Expected results:
access repo and provide list of available updates

Additional info:

Comment 1 Brad Buckingham 2016-05-17 17:48:37 UTC
Hi Sebastian, can you attach the client logs for review?  E.g. /var/log/messages

Comment 2 Sebastian Hetze 2016-05-22 13:58:35 UTC
Created attachment 1160302 [details]
messages from subscription-manager re-registration

Comment 3 Sebastian Hetze 2016-05-22 13:59:26 UTC
Created attachment 1160303 [details]
rhsm.log from subscription-manager re-registration

Comment 4 Sebastian Hetze 2016-05-22 14:04:29 UTC
Created attachment 1160304 [details]
redhat.repo with missing /pulp/repos in URL

Once I add /pulp/repos manually, access to the repositories works.

Comment 5 Brad Buckingham 2016-06-13 16:29:11 UTC
Hi Sabastian,  Can you attach the /etc/rhsm/rhsm.conf from the client that is seeing this behavior?

Also, do you know what the 'releasever' is that you are using for the content?  (e.g. 7Server, 7.1).

Comment 6 Sebastian Hetze 2016-06-16 11:59:13 UTC
Created attachment 1168708 [details]
rhsm.conf for client with missing /pulp/repos in the URL

Comment 7 Sebastian Hetze 2016-06-16 12:07:07 UTC
I only have 7Server synced into the Satellite.
No difference whatever I use for the content host.

The client says:
subscription-manager release
Release: 7Server


I will tear down the old Sat6.2 Beta and try again with the new Beta.
Maybe the problem disappears...

Comment 8 Bryan Kearney 2016-07-26 18:58:20 UTC
Moving 6.2 bugs out to sat-backlog.

Comment 9 Sebastian Hetze 2016-07-27 11:23:29 UTC
It appears that this problem is due to a previous call of subscription-manager with a wrong --baseurl

While the portal works with 

baseurl= https://cdn.redhat.com

Sat6 requires the pulp/repos prefix

baseurl= https://sat6.somewhere.org/pulp/repos

The manual page of subscription-manager gives the example:

 https://sam.example.com:8088/sam

It would be helpful to clarify the actual importance of the PREFIX and give an additional Sat6 example in the manual page for subscription-manager

Comment 11 Barnaby Court 2017-01-16 15:36:06 UTC
Closing as not a bug for Satellite. The upstream projects for RHEL 6 & 7 have BZs at BZ 1413161 and BZ 1413162 to update the subscription-manager man pages per comment 9


Note You need to log in before you can comment on or make changes to this bug.