Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 1413161 - Explain importance of prefix in man pages, add satellite 6 example
Explain importance of prefix in man pages, add satellite 6 example
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.4
Unspecified Unspecified
medium Severity low
: rc
: ---
Assigned To: Kevin Howell
John Sefler
: EasyFix, Triaged
Depends On:
Blocks: 1413162 1335382
  Show dependency treegraph
 
Reported: 2017-01-13 14:08 EST by Barnaby Court
Modified: 2018-04-10 05:48 EDT (History)
9 users (show)

See Also:
Fixed In Version: subscription-manager-1.20.2-1
Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: 1335382
: 1413162 (view as bug list)
Environment:
Last Closed: 2018-04-10 05:47:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github candlepin/subscription-manager/pull/1651 None None None 2017-06-05 14:26 EDT
Red Hat Product Errata RHBA-2018:0681 None None None 2018-04-10 05:48 EDT

  None (edit)
Comment 3 Rehana 2017-11-10 07:49:32 EST
on latest RHEL75 machine  having follows subscription-manager version

subscription-manager-rhsm-certificates-1.20.5-1.el7.x86_64
subscription-manager-gui-1.20.5-1.el7.x86_64
subscription-manager-rhsm-1.20.5-1.el7.x86_64
subscription-manager-1.20.5-1.el7.x86_64
subscription-manager-initial-setup-addon-1.20.5-1.el7.x86_64
subscription-manager-plugin-container-1.20.5-1.el7.x86_64

1) man rhsm.conf provides baseurl examples 


# man rhsm.conf | grep baseurl -A1
       baseurl
           This setting is the prefix for all content which is managed by the subscription service. This should be the hostname for the Red Hat CDN, the local Satellite or Capsule depending on your deployment.  Prefix depends on the service type.  For the Red Hat CDN, the full baseurl is https://cdn.redhat.com .  For Satellite 6, the baseurl is https://HOSTNAME/pulp/repos , so for a hostname of sat6.example.com the full baseurl would be for example: https://sat6.example.com/pulp/repos .


The subscription-manager man page is also updated with examples for the baseurl based on the deployment type

#man subscription-manager , grep for baseurl

       --baseurl=https://CONTENT_SERVICE:PORT/PREFIX
              Passes the name of the content delivery service to configure the yum service to use to pull down packages. If there is an on-premise subscription service such as Subscription Asset Manager or CloudForms  System  Engine,  this  parameter can be used to submit the URL of the content repository, in the form https://server_name:port/prefix.  PREFIX in particular depends on the service
type.  For example, https://sam.example.com:8088/sam is the baseurl for a SAM service.  https://sat6.example.com/pulp/repos is the  baseurl  for  a  Satellite  6  service  with  the  hostname sat6.example.com .  https://cdn.redhat.com is the baseurl for the Red Hat CDN.

As requested in the bug , its observed that now baseurl samples are given in the man pages of rhsm.conf and subscription-manager. 

based on the above observations , marking the bug as "Verified"
Comment 6 errata-xmlrpc 2018-04-10 05:47:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0681

Note You need to log in before you can comment on or make changes to this bug.