Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1335851 - The page does not load while accessing Content -> "Gpg Keys" on Satellite 6.2 Beta when having Any Context set
Summary: The page does not load while accessing Content -> "Gpg Keys" on Satellite 6.2...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.2.0
Hardware: All
OS: Linux
urgent
medium
Target Milestone: Unspecified
Assignee: Zach Huntington-Meath
QA Contact: Sanket Jagtap
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1340242 (view as bug list)
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker
TreeView+ depends on / blocked
 
Reported: 2016-05-13 11:51 UTC by Amit Upadhye
Modified: 2019-09-26 17:33 UTC (History)
7 users (show)

Fixed In Version: rubygem-katello-3.0.0.44-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 11:02:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 15221 0 None None None 2016-05-27 22:05:09 UTC

Description Amit Upadhye 2016-05-13 11:51:20 UTC
Description of problem:

On Satellite 6.2 when having Any Context set Content -> "GPG Keys" it throws 'Internal Server Error'(ISE)

Version-Release number of selected component (if applicable):

6.2.0 Beta

How reproducible:

Each time.

Steps to Reproduce:
1. Set Any Context from upper left hand side of page.
2. Navigate to 'Content'-> "GPG Keys" page.
3. Throws ISE on page.
 
Actual results:

Throws ISE.

Expected results:

Should give an option to select Organization to load page.

Additional info:

Comment 6 Zach Huntington-Meath 2016-05-27 21:35:23 UTC
Created redmine issue http://projects.theforeman.org/issues/15221 from this bug

Comment 7 Walden Raines 2016-06-01 21:15:12 UTC
*** Bug 1340242 has been marked as a duplicate of this bug. ***

Comment 8 Bryan Kearney 2016-06-02 18:16:02 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/15221 has been closed

Comment 9 Sanket Jagtap 2016-06-10 10:19:33 UTC
Build : Satellite 6.2 snap 14.1

For any context , It doesn't throw error on web UI , but it goes into Loading state forever.

But production-log , logs error

Comment 11 Zach Huntington-Meath 2016-06-10 15:23:01 UTC
This change was only rolled into Snap 15.1, please try testing it again in that. I know it went to ON-QA a few days ago, but there was some time between the snap being released and when the version of Katello containing the fix was built. Sorry for the confusion.

Comment 12 Marek Hulan 2016-06-13 10:09:48 UTC
Verified.

Version Tested:
Satellite-6.2.0-RHEL-7-20150429.2

After selecting any context and navigating to GPG keys I see the (empty) list of keys. I can also create, edit and delete a GPG key.

Comment 13 Bryan Kearney 2016-07-27 11:02:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.