Bug 133603 - system-config-packages should depend on dbus-python and probably something else?
system-config-packages should depend on dbus-python and probably something else?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-packages (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 133874 (view as bug list)
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-09-25 00:05 EDT by Ernst Persson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-14 08:10:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ernst Persson 2004-09-25 00:05:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; rv:1.7.3)
Gecko/20040914 Firefox/0.10

Description of problem:
Updated to the latest packages, and system-config-packages stopped
working.

First I saw that it was missing some dbus stuff, so I figured
dbus-python was needed. It was.

But it's still not working, getting a bit farther though.

[root@zapp ernstp]# system-config-packages 
Traceback (most recent call last):
  File "/usr/share/system-config-packages/MainWindow.py", line 160, in ?
    im = get_method(args)
  File "/usr/share/system-config-packages/config.py", line 89, in
get_method
    return method.RedHatCdromInstallMethod()
  File "/usr/share/system-config-packages/method.py", line 738, in
__init__
    CdromInstallMethod.__init__(self, device, mountpoint, alreadyMounted)
  File "/usr/share/system-config-packages/method.py", line 471, in
__init__
    self.cdlist = getCdDevs()
  File "/usr/share/system-config-packages/method.py", line 938, in
getCdDevs
    drives = hal_manager.FindDeviceByCapability('storage.cdrom')
  File "/usr/lib64/python2.3/site-packages/dbus.py", line 208, in __call__
    reply_message =
self._connection.send_with_reply_and_block(message, 5000)
  File "dbus_bindings.pyx", line 557, in
dbus_bindings.Connection.send_with_reply_and_block
dbus_bindings.DBusException: Service "org.freedesktop.Hal" does not exist


Version-Release number of selected component (if applicable):
system-config-packages-1.2.17-1 dbus-python-0.22-9

How reproducible:
Always

Steps to Reproduce:
Install FC3test2.
Update all packages.
Try to run system-config-packages
Install dbus-python
System-config-packages starts now, but crashes quickly.

Additional info:
Comment 1 Jef Spaleta 2004-09-25 00:15:57 EDT
I can confirm the dbus-python dep not being pulled in as a requirement.


As for the crash, its due to hal service not running. And this needs
to be filed as a seperate bug report. Its a seperate issue. And an
important one, so please refile it.  Applications that require hal to
be running shouldnt be crashing if hal isnt running, there should be
an attempt to exit gracefully with a message to inform the user that
the application can not run without hal.  

-jef
Comment 2 Jeremy Katz 2004-09-27 11:36:22 EDT
Will be fixed in 1.2.18
Comment 3 Jeremy Katz 2004-09-28 09:54:53 EDT
*** Bug 133874 has been marked as a duplicate of this bug. ***
Comment 4 Jay Turner 2004-10-14 08:10:06 EDT
system-config-packages-1.2.18-1 has added dependencies for 
hal >= 0:0.2.98
dbus-python

So that portion of the bug is taken care of.

Note You need to log in before you can comment on or make changes to this bug.