Bug 1336251 - [RFE][swift] Add internal method to increase ring partition power
Summary: [RFE][swift] Add internal method to increase ring partition power
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-swift
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 11.0 (Ocata)
Assignee: Christian Schwede (cschwede)
QA Contact: Mike Abrams
Don Domingo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-16 01:05 UTC by Sean Cohen
Modified: 2016-11-15 19:51 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-05 14:12:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 155107 0 None None None 2016-05-16 01:05:56 UTC
OpenStack gerrit 337297 0 None None None 2016-07-20 10:44:50 UTC

Description Sean Cohen 2016-05-16 01:05:56 UTC
This method increases the partition power of an existing ring by one. 
It does not move any data nor does it exposes a CLI command yet; it is only intended to be used in a future version to do the actual ring modification itself. 
If an operator stops the cluster, increases the partition power and renames & hardlinks the existing data it is possible to do a power shift without actually moving data. Please see the partition power spec for further details: http://specs.openstack.org/openstack/swift-specs/specs/in_progress/increasing_partition_power.html

Comment 3 Elise Gafford 2016-08-26 18:28:28 UTC
Per discussion with cshwede and the Swift team, moving this to 11.

Comment 5 Elise Gafford 2016-10-05 12:43:39 UTC
Adding needinfo on cschwede. Please discuss with zaitcev whether the following bug is a duplicate of this one: https://bugzilla.redhat.com/show_bug.cgi?id=1257300 and close the appropriate bug as a duplicate if appropriate.

Comment 6 Christian Schwede (cschwede) 2016-10-05 14:12:16 UTC
Closing this bug; the described method is already included in the upstream release. BZ#1257300 is still valid, because it exposes the method to the CLI, making it usable by the operator.


Note You need to log in before you can comment on or make changes to this bug.