Bug 133635 - Initscripts 7.84-1 does not like non initrd kernels
Initscripts 7.84-1 does not like non initrd kernels
Status: CLOSED DUPLICATE of bug 133465
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-09-25 09:50 EDT by Reuben Farrelly
Modified: 2014-03-16 22:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Reuben Farrelly 2004-09-25 09:50:40 EDT
After upgrading to Initscripts 7.84-1 and udev-032, I now get this 
message upon booting with a non-Fedora or other kernel not built with 
an initrd:

                Welcome to Fedora Core
                Press 'I' to enter interactive startup.
Mounting... tmpfs at /dev/:  mount: wrong fs type, bad option, bad 
superblock o,
       or too many mounted file systems
Making extra nodes:  ln: creating symbolic link `/dev//fd' to 
`/proc/self/fd': m
ln: creating symbolic link `/dev//stdin' to `/proc/self/fd/0': Read-
only file sm
ln: creating symbolic link `/dev//stdout' to `/proc/self/fd/1': Read-
only file m
ln: creating symbolic link `/dev//stderr' to `/proc/self/fd/2': Read-
only file m
ln: creating symbolic link `/dev//core' to `/proc/kcore': Read-only 
file system
MAKEDEV: error making /dev/fd1: Read-only file system
ln: creating symbolic link `/dev/MAKEDEV' to `/sbin/MAKEDEV': Read-
only file sym
[FAILED]
Starting udev:  rm: cannot remove `/dev//.udev.tdb': Read-only file 
system
[FAILED]
Initializing hardware...  storage network audio done[  OK  ]


This is because udev is now started much earlier on in the boot 
sequence - too early, in so far as it now starts before a rw 
filesystem is mounted on /dev.

It comes down to either building with an initrd, or using a Fedora 
kernel as a non-initrd kernel will not boot without this message.  It 
also screws up the operation of udev, which expects to have MAKEDEV 
and also the abovementioned devices available on boot.

To accomodate this, perhaps the initscripts could check for the 
presence of a rw /dev, and if not, either delay the udev start till 
after the filesystems have been mounted rw, or else mount a rw tmpfs 
on /dev so that start_udev can run without error  ?
Comment 1 Bill Nottingham 2004-09-27 11:41:28 EDT
The udev script already does mount /dev if needed. I suspect you're
running into a different bug.

*** This bug has been marked as a duplicate of 133465 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:53 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.