Bug 133639 - Screen resolution and color settings presented, selected but not activated.
Screen resolution and color settings presented, selected but not activated.
Status: CLOSED DUPLICATE of bug 135361
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-25 10:26 EDT by C.H.
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description C.H. 2004-09-25 10:26:39 EDT
Monitor: Sony-G500
Video card: ATI Radeon 9800 PRO 128M

Firstboot didn't detect the monitor for some reason, but presented
the Sony G500 from the list, and that was selected.

In the next dialog select boxes a large list of resolutions
were available, and the choice of thousands or millions of colors
was available.

I selected 1280x960 resolution with Millions of colors options and
that was accepted.

The video mode never changed, and when the login screen was presented
it was in 800x600.

Logging in as root and selecting Preferences -> Screen resolution
presents only "800x600" and "640x480" options, and nowhere is the
large list which was presented in firstboot listed.

To the extent that there's also a bug with respect to the
Preferences->Screen resolution application not seeing all the
available modes for the installed hardware, a bug also applies to 
that software as well as firstboot's presumably not plumbing the
right settings into the system hardware and X configuration files.

This is with a virgin FC3T2 X86_64 install with no updates applied.
Comment 1 C.H. 2004-09-25 11:18:13 EDT
From the original poster:
Concerning running:
/usr/bin/system-config-display
I noticed that when I enter the program the card is always
set to "ATI Radeon 9800" instead of the correct
"ATI Radeon 9800 PRO" which is another option, so it's not quite
detecting that properly.

When I entered 9800 PRO, and re-selected 1280x960 @ Millions of
colors, the program created a new X configuration, and informed that
a logout was required.  I did that, and the desired video mode did
then function properly.

After doing that there are many more resolution options available in
the Preferences -> Screen resolution application (not just the
800x600 and 640x480 as before), so that's more as it should be.

My first impression is that the Preferences -> Screen Resolution
application should in fact run /usr/bin/system-config-display
or at least give the user a direct option to do so if they want
more options than those presented by the screen resolution application
since it by itself was unable to achieve the correct configuration
whereas /usr/bin/system-config-display seems like it more generally
can configure things properly, and gives more options as well!

 
Comment 2 Paul Nasrat 2004-10-05 09:36:03 EDT
Can you attach the output of running as root:

kudzu -p -b ddc

and lspci -v

Also your current xorg.conf and that generated by
system-config-display --reconfig

Thanks
Comment 3 C.H. 2004-10-13 22:27:51 EDT
From the original submitter -- 

kudzu -p -b ddc
Generates no output whatsoever on the system in question.
The monitor is attached through a SVGA to BNC (RGB/H/V) cable
into the BNC monitor inputs, and I'm not sure if this configuration
is capable of sending DDC I/O to the monitor or not... maybe it's
possible to multiplex on one of those inputs, I don't know the
specification that well.  Anyway it gave no output.  I could try to
reconnect it through the VGA input on the monitor if needed, though
that isn't how it had been connected when I installed.

lspci -v gives --
[root@et ~]# lspci -v
00:00.0 Host bridge: VIA Technologies, Inc. VT8385 [K8T800 AGP] Host
Bridge (rev 01)
        Subsystem: VIA Technologies, Inc. VT8385 [K8T800 AGP] Host Bridge
        Flags: bus master, 66Mhz, medium devsel, latency 8
        Memory at d0000000 (32-bit, prefetchable) [size=256M]
        Capabilities: [80] AGP version 3.0
        Capabilities: [c0] HyperTransport: Slave or Primary Interface
        Capabilities: [68] Power Management version 2
        Capabilities: [58] HyperTransport: Interrupt Discovery and
Configuration

00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800
South] (prog-if 00 [Normal decode])
        Flags: bus master, 66Mhz, medium devsel, latency 0
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        I/O behind bridge: 0000c000-0000cfff
        Memory behind bridge: cfe00000-cfefffff
        Prefetchable memory behind bridge: afd00000-cfcfffff
        Capabilities: [80] Power Management version 2

00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169
Gigabit Ethernet (rev 10)
        Subsystem: Micro-Star International Co., Ltd.: Unknown device 702c
        Flags: bus master, 66Mhz, medium devsel, latency 32, IRQ 169
        I/O ports at ec00 [size=256]
        Memory at cfffff00 (32-bit, non-prefetchable) [size=256]
        Expansion ROM at cffc0000 [disabled] [size=128K]
        Capabilities: [dc] Power Management version 2

00:0f.0 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
(prog-if 8a [Master SecP PriP])
        Subsystem: Micro-Star International Co., Ltd.: Unknown device 7020
        Flags: bus master, medium devsel, latency 32, IRQ 177
        I/O ports at fc00 [size=16]
        Capabilities: [c0] Power Management version 2

00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 81) (prog-if 00 [UHCI])
        Subsystem: Micro-Star International Co., Ltd.: Unknown device 7020
        Flags: bus master, medium devsel, latency 32, IRQ 185
        I/O ports at dc00 [size=32]
        Capabilities: [80] Power Management version 2

00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 81) (prog-if 00 [UHCI])
        Subsystem: Micro-Star International Co., Ltd.: Unknown device 7020
        Flags: bus master, medium devsel, latency 32, IRQ 185
        I/O ports at e000 [size=32]
        Capabilities: [80] Power Management version 2

00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 81) (prog-if 00 [UHCI])
        Subsystem: Micro-Star International Co., Ltd.: Unknown device 7020
        Flags: bus master, medium devsel, latency 32, IRQ 185
        I/O ports at e400 [size=32]
        Capabilities: [80] Power Management version 2

00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 81) (prog-if 00 [UHCI])
        Subsystem: Micro-Star International Co., Ltd.: Unknown device 7020
        Flags: bus master, medium devsel, latency 32, IRQ 185
        I/O ports at e800 [size=32]
        Capabilities: [80] Power Management version 2

00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
(prog-if 20 [EHCI])
        Subsystem: Micro-Star International Co., Ltd.: Unknown device 7020
        Flags: bus master, medium devsel, latency 32, IRQ 185
        Memory at cffffd00 (32-bit, non-prefetchable) [size=256]
        Capabilities: [80] Power Management version 2

00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [K8T800
South]
        Subsystem: VIA Technologies, Inc. VT8237 ISA bridge [K8T800 South]
        Flags: bus master, stepping, medium devsel, latency 0
        Capabilities: [c0] Power Management version 2

00:11.5 Multimedia audio controller: VIA Technologies, Inc.
VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
        Subsystem: Micro-Star International Co., Ltd.: Unknown device 0080
        Flags: medium devsel, IRQ 193
        I/O ports at d800 [size=256]
        Capabilities: [c0] Power Management version 2

00:18.0 Host bridge: Advanced Micro Devices [AMD] K8
[Athlon64/Opteron] HyperTransport Technology Configuration
        Flags: fast devsel
        Capabilities: [80] HyperTransport: Host or Secondary Interface

00:18.1 Host bridge: Advanced Micro Devices [AMD] K8
[Athlon64/Opteron] Address Map
        Flags: fast devsel

00:18.2 Host bridge: Advanced Micro Devices [AMD] K8
[Athlon64/Opteron] DRAM Controller
        Flags: fast devsel

00:18.3 Host bridge: Advanced Micro Devices [AMD] K8
[Athlon64/Opteron] Miscellaneous Control
        Flags: fast devsel

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R350
[Radeon 9800 Pro] (prog-if 00 [VGA])
        Subsystem: ATI Technologies Inc: Unknown device 0002
        Flags: bus master, stepping, 66Mhz, medium devsel, latency 32,
IRQ 169
        Memory at c0000000 (32-bit, prefetchable) [size=128M]
        I/O ports at c800 [size=256]
        Memory at cfef0000 (32-bit, non-prefetchable) [size=64K]
        Expansion ROM at cfec0000 [disabled] [size=128K]
        Capabilities: [58] AGP version 3.0
        Capabilities: [50] Power Management version 2

01:00.1 Display controller: ATI Technologies Inc Radeon R350 [Radeon
9800 Pro] (Secondary)
        Subsystem: ATI Technologies Inc: Unknown device 0003
        Flags: bus master, stepping, 66Mhz, medium devsel, latency 32
        Memory at b8000000 (32-bit, prefetchable) [size=128M]
        Memory at cfee0000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [50] Power Management version 2

[
I'll monitor this bug for additional comments / questions in the
future; email is not a good way to reach me.  Thanks for looking at
this!

I'll probably install FC3T3 tomorrow so I'll see if I can get further
input with that OS.
Comment 4 Paul Nasrat 2004-10-20 04:54:16 EDT
Relooking makes me think that it is  bug # 135361

Closing as duplicate - please retest when the fixed
system-config-display is released, you should be able to rerun
firstboot by

rm -f /etc/sysconfig/firstboot
/sbin/chkconfig --add firstboot

And it'll run next boot

*** This bug has been marked as a duplicate of 135361 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:05:53 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.