Bug 135361 - firstboot: 'display' overwrites 'keyboard' settings
firstboot: 'display' overwrites 'keyboard' settings
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-keyboard (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
: 133639 136328 (view as bug list)
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-10-12 04:00 EDT by Tim Waugh
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-24 04:13:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2004-10-12 04:00:54 EDT
Description of problem:
If the keyboard setting is changed, the user(s) that were created on
the "Add a user" screen will get a message on login telling them that
their X keyboard setting and GNOME keyboard setting don't match, and
asking them which they want to use.

Version-Release number of selected component (if applicable):
system-config-keyboard-1.2.5-1
firstboot-1.3.28-2

How reproducible:
100%

Steps to Reproduce:
1. Kickstart with 'firstboot --reconfig'
2. Add a user during firstboot
3. Change keyboard setting during firstboot
4. Log in as the user
Comment 1 Tim Waugh 2004-10-12 05:39:44 EDT
Hmm, actually I'm wrong about the cause of this: the keyboard setting
is indeed before the user creation.

This seems to stem from the firstboot keyboard layout module not
setting xorg.conf properly.  Running system-config-keyboard from the
menu after login does set this properly, however.
Comment 2 Tim Waugh 2004-10-14 08:30:13 EDT
Here is the problem: both the 'keyboard' and 'display' modules load
the existing X settings, then the user screens are shown.  Whichever
one appears last wins, and overwrites the other's settings.
Comment 3 Tim Waugh 2004-10-14 08:51:59 EDT
Actually it seems to work to run 'display' at priority 19, i.e. just
before 'keyboard'.  Both changes get through then.

So perhaps that's the answer.
Comment 4 Paul Nasrat 2004-10-14 08:58:45 EDT
Yes although it really shouldn't break in this way.  Thanks for the
testing. I'll see if I can fix other than changing the priorities
Comment 5 Paul Nasrat 2004-10-19 07:37:20 EDT
*** Bug 136328 has been marked as a duplicate of this bug. ***
Comment 6 Paul Nasrat 2004-10-19 11:01:19 EDT
Should be fixed in system-config-display-1.0.23

Both myself and twaugh have tested.
Comment 7 Need Real Name 2004-10-20 03:19:29 EDT
Where can I download?
Comment 8 Paul Nasrat 2004-10-20 03:34:00 EDT
It should come through rawhide (fedora development) as normal.
Probably at around 11:00 UTC IIRC, though mirrors may be later.
Comment 9 Paul Nasrat 2004-10-20 04:54:25 EDT
*** Bug 133639 has been marked as a duplicate of this bug. ***
Comment 10 Need Real Name 2004-10-20 11:10:53 EDT
$ rpm -q system-config-display
system-config-display-1.0.23-1

Still broken for me.
The "z" key is showing as a "z" key in console and on the logon screen.
Once I'm logged in, it becomes a "y" key.

I have to run system-config-keyboard to fix it after every log in.

Are there any special instructions to get this to work?

I've tried:
running system-config-display, pressing OK.
running system-config-keyboard, pressing OK.

Logging out and in again.
Logging out and in again choosing "save current setup".

Restarting X.

# grep kbLayout xorg.conf
        Option      "XkbLayout" "de"
Comment 11 Paul Nasrat 2004-10-21 04:32:51 EDT
Can you create a new user for testing - you may have changed the
preferences within Gnome which system-config-keyboard does not affect.

Comment 12 Need Real Name 2004-10-21 08:26:12 EDT
Yes - that works. Thanks for fixing!

What do I need to change to fix existing users?
Comment 13 Paul Nasrat 2004-10-21 08:37:00 EDT
Hat->Preferences->Keyboard

Select the layout tab, reset to defaults or manually select.

Comment 14 Need Real Name 2005-03-16 09:29:38 EST
This seems broken again in FC4T1.

Fresh install: language US, keyboard German.

On entering X, I am asked which keyboard I want to use.
Comment 15 Need Real Name 2005-03-22 06:02:24 EST
WFM

Note You need to log in before you can comment on or make changes to this bug.