Bug 133654 - upgrade to bind 9.3.0 for FC3?
Summary: upgrade to bind 9.3.0 for FC3?
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
: 134529 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-25 19:36 UTC by James Ralston
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-03 21:23:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Ralston 2004-09-25 19:36:39 UTC
The ISC released both bind 9.2.4 and bind 9.3.0 on 2004-09-23.

Bind 9.2.4 is in the FC development tree; bind 9.3.0 is not.

If it's too late to consider putting bind 9.3.0 in FC3, could we at
least have it in the development tree?  I think as much advance
exposure to bind 9.3.0 as possible would be a Good Thing.

Comment 1 Daniel Roesen 2004-09-25 20:13:56 UTC
Totally agreed. Please consider upgrading to 9.3.0 before FC3. It's
the only version which implements the future DNSSEC specs and has the
ability to bind to a specific IPv6 interface.

Comment 2 Jason Vas Dias 2004-09-27 14:30:24 UTC
 BIND 9.2.4 (final version) will be in Fedora Core Test 3 (FC3t3)
 and Enterprise Linux 4 Beta 2 (RHEL-4-B2).
 As soon as these projects have both frozen (around Oct 13th) I
 will submit bind-9.3.0 to the FC3 development tree.
 There is not sufficient time for full testing of 9.3.0 for our GA 
 releases.
 Meanwhile, I will work on getting a "beta-test" BIND-9.3.0 RPM done
 today, which will be available at :
 http://people.redhat.com/~jvdias/bind/9.3.0 

 
 

Comment 3 Daniel Roesen 2004-09-27 14:36:14 UTC
OK, great. Will test 9.3.0 RPMs here on my name servers.

Comment 4 Jason Vas Dias 2004-09-27 17:26:30 UTC
 This is now done. You can download bind-9.3.0-1_beta from :
  http://people.redhat.com/~jvdias/bind/9.3.0
 
The srpm is at:
 http://people.redhat.com/~jvdias/bind/9.3.0/bind-9.3.0-1_beta.src.rpm
 
I have built the binary packages for the i386 platform which are here:
  http://people.redhat.com/~jvdias/bind/9.3.0/i386

These were built under the latest rawhide release of today(20040827).

If you need the packages for a different platform, download the srpm
and build it with:
   rpmbuild --rebuild bind-9.3.0-1_beta.src.rpm
 
Then install the resulting rpms which will be in
/usr/src/redhat/RPMS/i386.
 

Comment 5 Daniel Roesen 2004-09-27 19:00:23 UTC
When comparing 9.2.3-5 Fedora RPMs to your 9.3.0 beta, two utils
are missing in the "bind" subpackage:

-/usr/sbin/dnssec-makekeyset
-/usr/sbin/dnssec-signkey
-/usr/share/man/man8/dnssec-makekeyset.8.gz
-/usr/share/man/man8/dnssec-signkey.8.gz

Also, bind-utils doesn't contain the resolver.5 manpage anymore, I
guess this is now where it belongs (glibc)?

Now on to some production server tests...

Best regards,
Daniel

Comment 6 Jason Vas Dias 2004-10-04 14:07:42 UTC
*** Bug 134529 has been marked as a duplicate of this bug. ***

Comment 7 Lee Whatley 2004-10-04 14:11:18 UTC
Thanks for the link to the beta rpm!  This will work for me until
RHEL-4 is released.

Comment 8 Robert Scheck 2004-11-07 18:01:42 UTC
Could bind 9.3.0 pushed to Fedora Development, please?

Comment 9 Robert Scheck 2004-11-29 09:55:41 UTC
Ping? Rawhide?

Comment 10 Daniel Roesen 2004-11-29 10:06:44 UTC
The production server tests on two nameservers here went fine, no
problems whatsoever, running dual-stack IPv4/IPv6 for two months now.
FWIW...

Comment 11 Jason Vas Dias 2004-11-29 19:32:38 UTC
 bind-9.3.0-1 is now in FC4 / Rawhide, and is available for FC2 and FC3
 by download from:
    http://people.redhat.com/~jvdias/bind/9.3.0
 

Comment 12 James Ralston 2005-02-03 21:23:39 UTC
Confirmed that bind 9.3.0 is in FC development; closing.



Note You need to log in before you can comment on or make changes to this bug.