Bug 134529 - Feature Request: Backport IPv4/IPv6 dual-stack functionality into bind-9.2.4-EL3_10 or produce 9.3.0 RPM for RHEL 3
Summary: Feature Request: Backport IPv4/IPv6 dual-stack functionality into bind-9.2.4...
Status: CLOSED DUPLICATE of bug 133654
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: bind (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact: Ben Levenson
URL: http://www.isc.org/index.pl?/sw/bind/...
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-04 13:48 UTC by Lee Whatley
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:06:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lee Whatley 2004-10-04 13:48:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040803

Description of problem:
This is strictly a feature request.  The version of BIND that ships
with RHEL 3 (bind-9.2.4-EL3_10) does not support a dual-stack
IPv4/IPv6 environment.  ISC addressed this issue with the release of
BIND 9.3.0.  Many organizations that are planning to migrate to IPv6
first implement a dual-stack environment in order to ease the
transition and elimination of legacy IPv4-only applications and
services.  It is currently impossible to implement a DNS server using
the Redhat supplied BIND rpm's in a dual-stack environment.

Version-Release number of selected component (if applicable):
bind-9.2.4-EL3_10

How reproducible:
Always

Steps to Reproduce:
N/A    

Actual Results:  N/A

Expected Results:  N/A

Additional info:

FWIW, it seems that bind-9.2.4-EL3_10 works fine in an IPv4 only or
IPv6 only environment.  The only problem is with network topologies
that incorporate a dual protocol stack.

Comment 1 Jason Vas Dias 2004-10-04 14:05:23 UTC
 bind-9.3.0 should be in the next RHEL-4.0 release 
 (or rather, the Release Candidate #1 that will be
 released in December). bind-9.3.0's release last
 week did not give us sufficient time for testing
 to include it in the current RHEL-4. 
 Meanwhile, you can download it from :
 http://people.redhat.com/~jvdias/bind/9.3.0/bind-9.3.0-1_beta.src.rpm
 and build it with:
 $ rpmbuild --rebuild bind-9.3.0-1_beta.src.rpm
 Then install the RPMs that will be in 
 /usr/src/redhat/RPMS/i386/bind* .


Comment 2 Jason Vas Dias 2004-10-04 14:07:39 UTC

*** This bug has been marked as a duplicate of 133654 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:06:05 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.