Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1337068 - Virt-viewer problems while bad monitor mapping
Summary: Virt-viewer problems while bad monitor mapping
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Virt Viewer Maint
QA Contact: SPICE QE bug list
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-18 08:23 UTC by Radek Duda
Modified: 2016-08-02 12:58 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-02 12:58:00 UTC
Target Upstream Version:


Attachments (Terms of Use)
console_debug (3.03 KB, text/plain)
2016-05-18 08:23 UTC, Radek Duda
no flags Details

Description Radek Duda 2016-05-18 08:23:41 UTC
Created attachment 1158647 [details]
console_debug

previous discussion in bug 1129477 comment 48
Description of problem:

I have three monitors on my client. When I open Settings-> Displays they are numbered like this:
1 - Built-in
2 - NEC
3 - Acer.
I turned off Built-in display, so 
2 - NEC
3 - Acer.
are active.

I map the monitors like this:

1) ~/.config/virt-viewer:
[rhel7.3]
monitor-mapping=1:3;2:2

Now I try to connect $remote-viewer spice://localhost:5900
then I get warning message:
remote-viewer-WARNING **: Initial monitor #3 for display #1 does not exist, skipping...
remote-viewer-WARNING **: display 0 should not be enabled, disabling

So the result is that guest display is only on 2 - NEC monitor.

Now some problems arise:
a) in this configuration mouse sometimes (~30% reproducibility) doesn't work in guest (cursor appears, but cannot interact) and I must leave full-screen mode and go back to enable it

b) sometimes (~35% reproducibility) is mouse cursor invisible over displayed VM desktop (is it at the background??)

c) sometimes (~15% reproducibility) blank screen appears on the monitor 3 - Acer with message: "Connected to graphic server" and no guest display appears. The debug report (--debug) from c) case is attached.

d) everything works as expected (~20% reproducibility)


I researched little bit more:

2) monitor-mapping=1:2;2:3
then I get warning message:
remote-viewer-WARNING **: Initial monitor #3 for display #2 does not exist, skipping...
and guest display is again on 2 - NEC monitor. (no problem with mouse or blank screen)

In the case of
3) monitor-mapping=1:1;2:2
both guest displays are spread over two client monitors, but if I get display IDs in guest (setting -> Displays), (2 - NEC monitor) is guest display 2 and (3 - Acer) is guest display 1. 

For me it seems there is a mismatch in client monitor/guest display ID numbering. Would it be possible to reconcile the differences in numbering of gnome control panel with Gtk+ numbering? Or at least clarify the difference in virt-viewer documentation...

How reproducible:
as described above

Steps to Reproduce:
1. Create some VM
2. add monitor-mapping option to ~/.conf/virt-viewer/settings for particular VM
3. connect to VM :
    $remote-viewer spice://$IP_VM:$PORT_VM -f

Actual results:
as described above


Expected results:
One guest display will be displayed on one client monitor (no blank screen). Mouse cursor should be visible and interact properly.


Additional info:

Comment 2 Pavel Grunt 2016-05-19 09:59:37 UTC
Hi, what is the version of virt-viewer and spice-gtk ?

a) not sure, would be nice to have more info - see also the bug 1286785
b) also reminds me the bug 1286785
c) it is bug 1323092

About the monitor mapping - we take info about it from gtk. Would be nice to know if Windows client and RHEL6 client has the same issue.

Comment 3 Radek Duda 2016-05-19 14:55:14 UTC
(In reply to Pavel Grunt from comment #2)
> Hi, what is the version of virt-viewer and spice-gtk ?
> 
> a) not sure, would be nice to have more info - see also the bug 1286785
> b) also reminds me the bug 1286785
> c) it is bug 1323092
> 
> About the monitor mapping - we take info about it from gtk. Would be nice to
> know if Windows client and RHEL6 client has the same issue.

Sorry I have forgotten to add versions:
virt-viewer-2.0-7.el7.x86_64
qemu-kvm-1.5.3-112.el7.x86_64
spice-gtk-0.31-2.el7.x86_64

Concerning c) - yes it seems it is a bug 1286785


I tried to reproduce this issue on RHEL 6.8 and Windows 8 clients ((closed) monitor of notebook) and rhel7.3 guest
With this output:

RHEL6.8 latest build:
----------------------
spice-server-0.12.4-13.el6.1.x86_64
spice-gtk-0.26-7.el6.x86_64
virt-viewer-2.0-14.el6.x86_64
qemu-kvm-0.12.1.2-2.491.el6.x86_64

monitor-mapping=1:3;2:2 - almost same behaviour as denoted for rhel7.3 client, but I was not able to reproduce non-visible cursor (issue b))

interesting part:
================
* in the case of monitor-mapping=1:2;2:1 both guest displays were on the same client monitor
* during my first attempts mouse pointer changed shape from arrow to 1x1cm black square (only over guest display). I was not able to reproduce this after approx. 5th connection to guest.

Windows 8
---------
virt-viewer v.2.0-129
monitor-mapping=1:3;2:2 - almost same behaviour as denoted for rhel7.3 client, but I was not able to reproduce non-visible cursor (issue b))

monitor-mapping=1:2;2:1 worked well

Comment 4 Pavel Grunt 2016-08-02 11:26:00 UTC
Radek, I would suggest to open separate bugs for the issues you found - if there are still present - or please clarify what is missing.

a) + b) - seems to be fixed per https://bugzilla.redhat.com/show_bug.cgi?id=1286785#c22
c) is bug 1323092 - fixed in spice-gtk-0.31-3.el7

Comment 5 Radek Duda 2016-08-02 12:58:00 UTC
yes all the issues seems to be fixed. I have tested it with rhel 7.3, rhel 6.8 and win7 guests (and rhel 7.3 client/host). If I supply incorrect monitor-mapping configuration, both displays are matched to client monitors and 

(remote-viewer:19098): remote-viewer-WARNING **: Invalid monitor-mapping configuration: monitor #3 for display #1 does not exist 

message appears.

Closing this.


Note You need to log in before you can comment on or make changes to this bug.