This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 133713 - (firefox & thunderbird) remove or fix default app check
(firefox & thunderbird) remove or fix default app check
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
: 135578 (view as bug list)
Depends On:
Blocks: FC3Target 131589
  Show dependency treegraph
 
Reported: 2004-09-26 14:50 EDT by Bill Nottingham
Modified: 2014-03-16 22:48 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-19 23:05:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2004-09-26 14:50:17 EDT
My default web browser is 'firefox %s'.

firefox complained that it wasn't the default, and helpfully changed
it to /usr/lib/firefox-<blah>/firefox %s.

Which breaks how it opens new windows.
Comment 1 Warren Togami 2004-09-26 22:40:38 EDT
Totally in agreement.  It should check and set "firefox %s" exactly as
/usr/bin/gnome-default-applications-properties does so.
Comment 2 Warren Togami 2004-10-07 04:25:31 EDT
This fixes the setting of the gconf keys, but I don't understand
nsGNOMEShellService::IsDefaultBrowser() in nsGNOMEShellService.cpp
where the checking part must also be fixed.

--- mozilla/browser/components/shell/src/nsGNOMEShellService.cpp.orig
  2004-10-06 18:20:53.279343935 -1000
+++ mozilla/browser/components/shell/src/nsGNOMEShellService.cpp     
  2004-10-06 18:21:25.317972727 -1000
@@ -228,7 +228,7 @@
   nsCOMPtr<nsIGConfService> gconf =
do_GetService(NS_GCONFSERVICE_CONTRACTID);

   nsCAutoString schemeList;
-  nsCAutoString appKeyValue(mAppPath + NS_LITERAL_CSTRING(" \"%s\""));
+  nsCAutoString appKeyValue(NS_LITERAL_CSTRING("firefox %s"));
   unsigned int i;

   for (i = 0; i < NS_ARRAY_LENGTH(appProtocols); ++i) {
Comment 3 Christopher Aillon 2004-10-07 13:57:20 EDT
It has no business even checking at all. 
https://bugzilla.mozilla.org/show_bug.cgi?id=263214
Comment 4 Warren Togami 2004-10-08 03:21:17 EDT
Ok, then the check should be removed from both firefox and thunderbird.
Comment 8 Warren Togami 2004-10-13 16:27:59 EDT
*** Bug 135578 has been marked as a duplicate of this bug. ***
Comment 9 Christopher Aillon 2004-10-19 23:05:39 EDT
I got this for firefox, and looks like blizzard nailed it for
thunderbird.  Marking RAWHIDE

Note You need to log in before you can comment on or make changes to this bug.