Bug 135578 - firefox doesn't set itself up correctly as preferred gnome web browser
firefox doesn't set itself up correctly as preferred gnome web browser
Status: CLOSED DUPLICATE of bug 133713
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Depends On:
  Show dependency treegraph
Reported: 2004-10-13 13:02 EDT by Thomas J. Baker
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:06:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Thomas J. Baker 2004-10-13 13:02:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041012

Description of problem:
Firefox sets itself up wrong as the default gnome web browser. First I
set Firefox up to be the default web browser using Preferences->More
Preferences->Preferred Applications. If I then launch firefox directly
or have it launched by evolution from a link, two things to note.
First, it prompts that it's not the default web browser, would you
like to make it the default. Note I just said I set it to be the
default in the preferences. Selecting yes causes it to set itself up
wrong as the default gnome browser. A quick check of about:plugins
shows all system installed plugins available. Note this is the same
initial invocation. Now quit firefox and launch it via a link in
evolution. Check about:plugins and see none (or at least no system
wide plugins that hang out in /usr/lib/mozilla/plugins.) Now quit and
launch it again from the menu or a launcher and the system wide
plugins are there. So however firefox sets itself up as the preffered
gnome web browser makes it not search system directories for plugins.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. see above

Additional info:
Comment 1 Warren Togami 2004-10-13 16:27:47 EDT

*** This bug has been marked as a duplicate of 133713 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:17 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.