Bug 1337130 - Revert "glusterd/afr: store afr pending xattrs as a volume option" patch on 3.8 branch
Summary: Revert "glusterd/afr: store afr pending xattrs as a volume option" patch on 3...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: 3.8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ravishankar N
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: glusterfs-3.8.0
TreeView+ depends on / blocked
 
Reported: 2016-05-18 11:28 UTC by Ravishankar N
Modified: 2016-06-16 14:07 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-16 14:07:31 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Ravishankar N 2016-05-18 11:28:04 UTC
Revert "glusterd/afr: store afr pending xattrs as a volume option"
    
The patch was introduced by commit 6e635284a4411b816d4d860a28262c9e6dc4bd6a in the release-3.8 branch. The commit itself was inherited from http://review.gluster.org/#/c/12738/ in master when the branch was created.
    
Reverting it for the same reason it was reverted in 3.7 branch as well:
It breaks the rolling upgrade scenario and these changes will be required only when server side AFR materializes, possibly for gluster 4.0.

Comment 1 Vijay Bellur 2016-05-18 11:29:12 UTC
REVIEW: http://review.gluster.org/14414 (Revert glusterd/afr: store afr pending xattrs as a volume option) posted (#1) for review on release-3.8 by Ravishankar N (ravishankar@redhat.com)

Comment 2 Vijay Bellur 2016-05-19 04:25:35 UTC
COMMIT: http://review.gluster.org/14414 committed in release-3.8 by Vijay Bellur (vbellur@redhat.com) 
------
commit 4af3ddd26b53ea2f2d7923ba097946deee46f527
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Wed May 18 11:21:39 2016 +0000

    Revert glusterd/afr: store afr pending xattrs as a volume option
    
    This patch reverts changes introduced by commit
    6e635284a4411b816d4d860a28262c9e6dc4bd6a in the release-3.8 branch. The
    commit itself was inherited from http://review.gluster.org/#/c/12738/ in
    master when the branch was created.
    
    Reverting it for the same reason it was reverted in 3.7 branch as well:
    It breaks the rolling upgrade scenario and these changes will be
    required only when server side AFR materializes, possibly for gluster
    4.0.
    
    Change-Id: Ib3bb78994d7375f7c34df9897dfaf653ea909924
    BUG: 1337130
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/14414
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 3 Niels de Vos 2016-06-16 14:07:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.