Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1337566 - Remove ImmDisableIME call without issues
Summary: Remove ImmDisableIME call without issues
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer
Version: 7.2
Hardware: Unspecified
OS: Windows
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Virt Viewer Maint
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1342984
TreeView+ depends on / blocked
 
Reported: 2016-05-19 13:25 UTC by Frediano Ziglio
Modified: 2016-06-06 09:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1342984 (view as bug list)
Environment:
Last Closed: 2016-06-06 09:34:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1297640 0 high CLOSED Remote-viewer application unable to send some keys due to IME not disabled 2021-02-22 00:41:40 UTC

Internal Links: 1297640

Description Frediano Ziglio 2016-05-19 13:25:30 UTC
Description of problem:
To solve some issue with Japanese keyboard and some IME settings ImmDisableIME is called. This however cause (on Windows 7) the keyboard taskbar applet to be hidden so user cannot easily change input method when virt-viewer is on focus.

Version-Release number of selected component (if applicable):
Last one with Japanese fixes.


How reproducible:
Always


Steps to Reproduce:
1. Use Windows 7 machine
2. Set a Japanese keyboard.
3. Install new virt-viewer.
4. Open a remote machine
5. Note that icon to change keyboard is hidden.


Actual results:
Icon get hidden


Expected results:
Icon visible, possible to switch IME/keyboard


Additional info:
One issue without ImmDisableIME is that pressing on the title of virt-viewer application with Hiragana input selected (as default and when the application is open) and start typing a new window get the keyboard input.
On other input methods (still with a Japanese keyboard) key events are not sent to the remote machine.
One possible solution would be to always hook and filter the keyboard at low level before Windows attempt to process IME inputs (so getting raw keystrokes).
Currently hook is installed only at some stricter condition and can be disabled.
in different ways.

Comment 2 Fabiano Fidêncio 2016-06-06 09:34:42 UTC
I can't  move this bug to the right component, as "A value must be set for the 'oVirt Team' field."

So, I've cloned the bug there and I'm closing it here.
For any further discussion, please, https://bugzilla.redhat.com/show_bug.cgi?id=1342984 is the proper place for it.


Note You need to log in before you can comment on or make changes to this bug.