Bug 1337597 - Mounting a volume over NFS with a subdir followed by a / returns "Invalid argument"
Summary: Mounting a volume over NFS with a subdir followed by a / returns "Invalid arg...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: nfs
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1337596
TreeView+ depends on / blocked
 
Reported: 2016-05-19 14:58 UTC by Niels de Vos
Modified: 2017-03-27 18:11 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1337596
Environment:
Last Closed: 2017-03-27 18:11:33 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2016-05-19 14:58:35 UTC
+++ This bug was initially created as a clone of Bug #1337596 +++

Description of problem:


Mounting a volume over NFS with a subdir followed by a / does not work:

  # mount -t nfs -o vers=3 storage.example.com:/media/installation/ /mnt
  mount.nfs: an incorrect mount option was specified

In the nfs.log:

  [client-rpc-fops.c:2930:client3_3_lookup_cbk] 0-media-client-0: remote operation failed. Path: /installation/ (00000000-0000-0000-0000-000000000000) [Invalid argument]
  [client-rpc-fops.c:2930:client3_3_lookup_cbk] 0-media-client-1: remote operation failed. Path: /installation/ (00000000-0000-0000-0000-000000000000) [Invalid argument]
  [mount3.c:1134:mnt3_resolve_subdir_cbk] 0-nfs: path=/installation/ (Invalid argument) [Invalid argument]



Version-Release number of selected component (if applicable):
glusterfs-3.8rc0

Comment 1 Vijay Bellur 2016-05-19 15:00:40 UTC
REVIEW: http://review.gluster.org/14421 (nfs: testcase for subdir mounting with a trailing /) posted (#3) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 2 Vijay Bellur 2016-05-20 07:26:23 UTC
REVIEW: http://review.gluster.org/14421 (nfs: strip trailing / when clients do subdir mounts) posted (#4) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 3 Vijay Bellur 2016-05-23 13:20:42 UTC
COMMIT: http://review.gluster.org/14421 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 6c936a0da3f5f56dd711169f7eb8d335bbb8cdc7
Author: Niels de Vos <ndevos@redhat.com>
Date:   Thu May 19 12:53:09 2016 +0200

    nfs: strip trailing / when clients do subdir mounts
    
    Mounting a volume over NFS with a subdir followed by a / does not work:
    
      # mount -t nfs -o vers=3 storage.example.com:/media/installation/ /mnt
      mount.nfs: an incorrect mount option was specified
    
    In the nfs.log:
    
      [client-rpc-fops.c:2930:client3_3_lookup_cbk] 0-media-client-0: remote operation failed. Path: /installation/ (00000000-0000-0000-0000-000000000000) [Invalid argument]
      [client-rpc-fops.c:2930:client3_3_lookup_cbk] 0-media-client-1: remote operation failed. Path: /installation/ (00000000-0000-0000-0000-000000000000) [Invalid argument]
      [mount3.c:1134:mnt3_resolve_subdir_cbk] 0-nfs: path=/installation/ (Invalid argument) [Invalid argument]
    
    It is not possible to resolve paths with a trailing /. Stripping
    trailing /'s from the subdir to mount is sufficient to make it work
    again.
    
    Change-Id: I4075d4cd351438de58e1ff81f0fb65a1ff076da4
    BUG: 1337597
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/14421
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: jiffin tony Thottan <jthottan@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 4 Shyamsundar 2017-03-27 18:11:33 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.