Bug 1337664 - [RFE] [Sahara] Add new MapR 5.1 plugin (add-mapr-510)
Summary: [RFE] [Sahara] Add new MapR 5.1 plugin (add-mapr-510)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-sahara
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: Upstream M3
: 11.0 (Ocata)
Assignee: Elise Gafford
QA Contact: Luigi Toscano
URL:
Whiteboard:
: 1338983 (view as bug list)
Depends On: 1393956 1434521 1434864
Blocks: 1379927 1422755
TreeView+ depends on / blocked
 
Reported: 2016-05-19 18:41 UTC by Rob Young
Modified: 2017-05-17 19:30 UTC (History)
15 users (show)

Fixed In Version: openstack-sahara-5.0.0-0.20160823145105.1a24d87.el7ost
Doc Type: Enhancement
Doc Text:
This update adds support for the version 5.1.0 MapR plugin.
Clone Of:
Environment:
Last Closed: 2017-05-17 19:30:29 UTC
scohen: needinfo+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC

Description Rob Young 2016-05-19 18:41:00 UTC
Description of problem:

MapR introduces new 5.1.0 version. This version should be added to sahara MapR plugin.

Upstream BP is here: https://blueprints.launchpad.net/sahara/+spec/add-mapr-510

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Elise Gafford 2016-08-15 16:59:48 UTC
Note: not yet implemented for CentOS 7. Discussion around continued CentOS 6 support in OSP 10 or rapid development of a CentOS 7 image needed.

Comment 4 Elise Gafford 2016-08-26 18:19:23 UTC
*** Bug 1338983 has been marked as a duplicate of this bug. ***

Comment 6 Elise Gafford 2016-09-16 17:44:09 UTC
Note: Known zookeeper issue is being fixed upstream. See https://review.openstack.org/#/c/371361/2 . We need to ensure that this is backported to stable/newton and our product prior to release.

Comment 8 Elise Gafford 2016-12-07 13:35:03 UTC
Moving to 11; will pull back to 10.0.z pending PM call on plugin release to minor versions.

Comment 17 Luigi Toscano 2017-03-30 07:40:18 UTC
An image based on RHEL 7.3 + MapR bits can be generated using sahara-image-elements and the same image works when fed to the MapR 5.1 plugin and the sahara-scenario tests (create a cluster, run some jobs, scale with an additional node, rerun the jobs).
The 5.1 plugin needs to be enabled (as it is deprecated and so disabled by default).

Captured stdout:
~~~~~~~~~~~~~~~~
    All tests for Cinder were skipped
    Results of testing plugin mapr 5.1.0.mrv2
    +-----------------------------+--------+-------------+----------------------------+
    | Check                       | Status | Duration, s |         Start time         |
    +-----------------------------+--------+-------------+----------------------------+
    | Create node group templates |   OK   |      2      | 2017-03-29 21:56:53.640706 |
    | Set flavor                  |   OK   |      0      | 2017-03-29 21:56:54.272000 |
    | Set flavor                  |   OK   |      0      | 2017-03-29 21:56:55.398809 |
    | Create cluster template     |   OK   |      1      | 2017-03-29 21:56:55.963955 |
    | Create cluster              |   OK   |      6      | 2017-03-29 21:56:57.487864 |
    | Check cluster state         |   OK   |     1529    | 2017-03-29 21:57:03.515289 |
    | Check cinder volumes        |   OK   |      0      | 2017-03-29 22:22:34.214719 |
    | Check event logs            |   OK   |      0      | 2017-03-29 22:22:35.585352 |
    | Check EDP jobs              |   OK   |     477     | 2017-03-29 22:22:35.586588 |
    | Check cluster verification  |   OK   |      99     | 2017-03-29 22:28:53.632151 |
    | Cluster scaling             |   OK   |     1546    | 2017-03-29 22:30:33.376560 |
    | Check EDP jobs              |   OK   |     600     | 2017-03-29 22:56:20.283294 |
    | Check cluster verification  |   OK   |     214     | 2017-03-29 23:02:46.336457 |
    +-----------------------------+--------+-------------+----------------------------+

Verified a TripleO-deployed cluster (1 controller, 1 compute).

Image building:
sahara-image-elements-6.0.0-7.el7ost.noarch
diskimage-builder-1.27.1-0.20170302013848.65c6da5.el7ost.noarch
dib-utils-0.0.11-1.el7ost.noarch

Sahara:
openstack-sahara-6.0.0-3.el7ost.noarch
openstack-sahara-api-6.0.0-3.el7ost.noarch
openstack-sahara-common-6.0.0-3.el7ost.noarch
openstack-sahara-engine-6.0.0-3.el7ost.noarch
puppet-sahara-10.3.0-2.el7ost.noarch
python-sahara-6.0.0-3.el7ost.noarch
python-saharaclient-1.1.0-1.el7ost.noarch

Comment 18 errata-xmlrpc 2017-05-17 19:30:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.