Bug 1338983 - RFE: MapR and Apache Vanilla Support in Sahara Image Elements
Summary: RFE: MapR and Apache Vanilla Support in Sahara Image Elements
Keywords:
Status: CLOSED DUPLICATE of bug 1337664
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: sahara-image-elements
Version: 8.0 (Liberty)
Hardware: All
OS: All
unspecified
low
Target Milestone: ---
: 10.0 (Newton)
Assignee: RHOS Maint
QA Contact: Luigi Toscano
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-23 20:02 UTC by Jon Jozwiak
Modified: 2016-08-26 18:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-26 18:19:23 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jon Jozwiak 2016-05-23 20:02:18 UTC
Description of problem:

MapR and Apache Vanilla plugins are released in the stable Liberty repos for sahara-image-elements, but are not included in RHEL OSP 8.  MapR and Vanilla apache images cannot be created without manually cloning the Liberty repo branch from upstream.  


Version-Release number of selected component (if applicable):
RHEL OSP 8 
sahara-image-elements-3.0.0-3.el7ost.noarch

How reproducible:
The functionality is not there so it can be reproduced every time 



Steps to Reproduce:
1. Get rhel 6 cloud image 
2. Export RHN credentials
   export DIB_RHSM_USER="USERNAME"
   export DIB_RHSM_PASSWORD="YOUR_PASSWORD"
   export DIB_RHSM_POOL="YOUR_SUBSCRIPTION_POOL"
3. Build image
sahara-image-create -p mapr

Actual results:
Unknown plugin selected.
Aborting

Expected results:
A MapR image should be built 

Additional info:
There are elements needed as well as the diskimage-create.sh script updated to support this.

Comment 2 Elise Gafford 2016-08-17 17:55:35 UTC
As of 9.0 we have ceased to remove the elements involved in building images for unsupported plugins from the sahara-image-elements package, and are only removing their options from the wrapper script. We are currently targeting full support of MapR for 10.0, though we are unlikely to support the vanilla plugin, as there is no support vendor for upstream Hadoop, Spark, or Storm.

Comment 3 Elise Gafford 2016-08-26 18:19:23 UTC
We have an RFE open for the introduction of MapR in the product as a whole (for both the sahara core repository and for sahara-image-elements.) Because we will never introduce full support of the vanilla plugin into the product (as there is no support vendor,) and as the remainder of this request is therefore a subset of the work described by that RFE, I am closing this bug as a duplicate of 1337664. Jon, I have added you to the cc list on that bug.

*** This bug has been marked as a duplicate of bug 1337664 ***


Note You need to log in before you can comment on or make changes to this bug.