Bug 133847 - kernel panic at boot because of bad scsi modules (e.g. aic7xxx or mpt_base)
kernel panic at boot because of bad scsi modules (e.g. aic7xxx or mpt_base)
Status: CLOSED DUPLICATE of bug 133848
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-27 16:54 EDT by Stephanie Lockwood-Childs
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephanie Lockwood-Childs 2004-09-27 16:54:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
Some of the scsi drivers in this kernel package cannot be loaded.  
After upgrading from update 2 to update 3 of kernel-smp package, boot 
fails in a kernel panic when driver for the scsi controller fails to 
load.

So far this problem has been observed for 2 different scsi drivers, 
aic7xxx and mpt. 

Version-Release number of selected component (if applicable):
kernel-smp-2.4.21-20.EL 

How reproducible:
Always

Steps to Reproduce:
1.upgrade to latest kernel-smp rpm 
2.reboot


Actual Results:  System fails to boot -- panics after the attempt to 
load scsi driver from ramdisk fails with unresolved symbol errors

Expected Results:  System should still boot normally after kernel 
upgrade

Additional info:

The addon modules directory included earlier versions of the mpt 
driver for the fusion controller, and these versions are able to be 
loaded (I manually included those modules in a ramdisk and got the 
system to boot). Whatever went wrong in the build only affected the 
drivers in the main scsi driver tree.
Comment 1 Ernie Petrides 2004-09-27 21:59:28 EDT

*** This bug has been marked as a duplicate of 133848 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.