Bug 133848 - kernel panic at boot because of bad scsi modules (e.g. aic7xxx or mpt_base)
kernel panic at boot because of bad scsi modules (e.g. aic7xxx or mpt_base)
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Tom Coughlan
:
: 133847 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-27 16:55 EDT by Stephanie Lockwood-Childs
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 07:59:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stephanie Lockwood-Childs 2004-09-27 16:55:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
Some of the scsi drivers in this kernel package cannot be loaded.  
After upgrading from update 2 to update 3 of kernel-smp package, boot 
fails in a kernel panic when driver for the scsi controller fails to 
load.

So far this problem has been observed for 2 different scsi drivers, 
aic7xxx and mpt. 

Version-Release number of selected component (if applicable):
kernel-smp-2.4.21-20.EL 

How reproducible:
Always

Steps to Reproduce:
1.upgrade to latest kernel-smp rpm 
2.reboot


Actual Results:  System fails to boot -- panics after the attempt to 
load scsi driver from ramdisk fails with unresolved symbol errors

Expected Results:  System should still boot normally after kernel 
upgrade

Additional info:

The addon modules directory included earlier versions of the mpt 
driver for the fusion controller, and these versions are able to be 
loaded (I manually included those modules in a ramdisk and got the 
system to boot). Whatever went wrong in the build only affected the 
drivers in the main scsi driver tree.
Comment 1 Stephanie Lockwood-Childs 2004-09-27 18:46:13 EDT
Here are the unresolved symbols for the aic7xx driver (have not been 
able to reboot server with LSI controller yet)

unresolved symbol _diskdump_mod_timer_Rsmp_149821d8
unresolved symbol _diskdump_del_timer_Rsmp_6e4ae275
unresolved symbol _diskdump_tasklet_schedule_Rsmp_acd0d2f4
unresolved symbol _diskdump_add_timer_Rsmp_23163dfb
Comment 2 Ernie Petrides 2004-09-27 21:59:36 EDT
*** Bug 133847 has been marked as a duplicate of this bug. ***
Comment 3 Tom Coughlan 2004-09-28 17:47:01 EDT
The unresolved symbols belong to diskdumplib.o (added in U3 to support
disk-based dump).  The aic7xxx and mpt fusion drivers in U3 depend on
diskdumplib.o. This should have been picked up during the install, and
diskdumplib.o should be in the initrd.

Is diskdumplib listed in /etc/modules.conf?

What procedure did you use to update the system? Were there any errors?
Comment 4 Josef Bacik 2004-09-29 12:28:26 EDT
alias eth0 tg3
alias eth1 tg3
alias eth2 e1000
alias eth3 e1000
alias scsi_hostadapter mptbase
alias scsi_hostadapter1 mptscsih
alias scsi_hostadapter2 mptscsih
alias scsi_hostadapter3 mptscsih
alias usb-controller off
options scsi_mod max_scsi_luns=255
options agpgart agp_try_unsupported=1


Is her modules.conf file.
Comment 5 Stephanie Lockwood-Childs 2004-09-29 19:30:54 EDT
It was an update problem -- kernel was upgraded without upgrading 
mkinitrd first. Problem resolved, thanks.

Note You need to log in before you can comment on or make changes to this bug.