Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1338495 - Remove collection of vm_disk_interface from base_disks
Summary: Remove collection of vm_disk_interface from base_disks
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine-dwh
Classification: oVirt
Component: ETL
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.0.0-rc
: 4.0.0
Assignee: Shirly Radco
QA Contact: Lukas Svaty
URL:
Whiteboard:
: 1340639 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-22 06:11 UTC by Shirly Radco
Modified: 2016-07-05 07:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: An option for multiple disk interfaces per vm was added in the engine and it was removed from base_disks table. Consequence: ELT process was broken Fix: Removed collection of vm disks interfaces, removed "vm_disk_interface" field from vm_disk_configuration table and related views. Result: This metric is not collected anymore.
Clone Of:
Environment:
Last Closed: 2016-07-05 07:59:43 UTC
oVirt Team: Metrics
rule-engine: ovirt-4.0.0+
lsvaty: testing_plan_complete-
rule-engine: planning_ack+
sradco: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 57864 0 master MERGED history:remove collection of vm_disk_interface 2020-09-22 13:55:27 UTC

Description Shirly Radco 2016-05-22 06:11:33 UTC
Description of problem:
An option  for multiple disk interfaces per vm was added in the engine.
This requires an update to the etl process.
Remove "vm_disk_interface" field from vm_disk_configuration table and related views.


Version-Release number of selected component (if applicable):
4.0

Actual results:
Without this change dwh is broken and sampling will fail.

Expected results:
DWH sampling and aggregations should work with no errors.

Additional info:

Comment 1 Shirly Radco 2016-05-23 11:25:35 UTC
I removed the "vm_disk_interface" field from the views and from the data  collection.

Did not remove the field from the history db.

This should solve the dwh from braking.

Yaniv, Do we want add the collection of the new disk_vm_element table, or remove this field ?

Comment 2 Yaniv Lavi 2016-05-23 13:20:21 UTC
oVirt 4.0 beta has been released, moving to RC milestone.

Comment 3 Yaniv Lavi 2016-05-23 13:23:56 UTC
oVirt 4.0 beta has been released, moving to RC milestone.

Comment 4 Shirly Radco 2016-05-29 17:55:08 UTC
*** Bug 1340639 has been marked as a duplicate of this bug. ***

Comment 5 Yaniv Lavi 2016-06-02 12:09:21 UTC
(In reply to Shirly Radco from comment #1)
> I removed the "vm_disk_interface" field from the views and from the data 
> collection.
> 
> Did not remove the field from the history db.
> 
> This should solve the dwh from braking.
> 
> Yaniv, Do we want add the collection of the new disk_vm_element table, or
> remove this field ?

Let's not re-add it. Moving to ON_QA.

Comment 6 Lukas Svaty 2016-06-24 10:13:40 UTC
sanity only, verified in ovirt-engine-dwh-4.0.0-2.el7ev.noarch

Comment 7 Sandro Bonazzola 2016-07-05 07:59:43 UTC
oVirt 4.0.0 has been released, closing current release.


Note You need to log in before you can comment on or make changes to this bug.