Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1338512 - ovirt-guest-agent 1.0.12 not working on CentOS with Docker
Summary: ovirt-guest-agent 1.0.12 not working on CentOS with Docker
Keywords:
Status: CLOSED DUPLICATE of bug 1337941
Alias: None
Product: ovirt-guest-agent
Classification: oVirt
Component: Core
Version: 1.0.12
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.0.0-rc
: ---
Assignee: Vinzenz Feenstra [evilissimo]
QA Contact: Pavel Stehlik
URL:
Whiteboard:
: 1338518 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-22 10:11 UTC by Sandro Bonazzola
Modified: 2016-05-23 07:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-23 07:08:55 UTC
oVirt Team: Virt
michal.skrivanek: ovirt-4.0.0?
rule-engine: planning_ack?
michal.skrivanek: devel_ack+
rule-engine: testing_ack?


Attachments (Terms of Use)

Description Sandro Bonazzola 2016-05-22 10:11:44 UTC
On CentOS:

# rpm -qv docker ovirt-guest-agent-common
docker-1.9.1-40.el7.centos.x86_64
ovirt-guest-agent-common-1.0.12-1.el7.noarch


Description of problem:
[root@docker ~]# service ovirt-guest-agent status -l
Redirecting to /bin/systemctl status  -l ovirt-guest-agent.service
● ovirt-guest-agent.service - oVirt Guest Agent
   Loaded: loaded (/usr/lib/systemd/system/ovirt-guest-agent.service; enabled; vendor preset: disabled)
   Active: active (running) since dom 2016-05-22 06:08:27 EDT; 39s ago
  Process: 3584 ExecStartPre=/bin/chown ovirtagent:ovirtagent /run/ovirt-guest-agent.pid (code=exited, status=0/SUCCESS)
  Process: 3582 ExecStartPre=/bin/touch /run/ovirt-guest-agent.pid (code=exited, status=0/SUCCESS)
  Process: 3580 ExecStartPre=/sbin/modprobe virtio_console (code=exited, status=0/SUCCESS)
 Main PID: 3586 (python)
   Memory: 10.0M
   CGroup: /system.slice/ovirt-guest-agent.service
           └─3586 /usr/bin/python /usr/share/ovirt-guest-agent/ovirt-guest-agent.py

mag 22 06:08:28 docker.home userhelper[3594]: running '/usr/share/ovirt-guest-agent/container-list' with root privileges on behalf of 'ovirtagent'
mag 22 06:08:28 docker.home python[3586]: Unhandled exception in thread started by <bound method LinuxVdsAgent.doWork of <GuestAgentLinux2.LinuxVdsAgent instance at 0x7f4005e55e60>>
mag 22 06:08:28 docker.home python[3586]: Traceback (most recent call last):
mag 22 06:08:28 docker.home python[3586]: File "/usr/share/ovirt-guest-agent/OVirtAgentLogic.py", line 227, in doWork
mag 22 06:08:28 docker.home python[3586]: self.sendTimezone()
mag 22 06:08:28 docker.home python[3586]: File "/usr/share/ovirt-guest-agent/OVirtAgentLogic.py", line 390, in sendTimezone
mag 22 06:08:28 docker.home python[3586]: ti = self.dr.getTimezoneInfo()
mag 22 06:08:28 docker.home python[3586]: File "/usr/share/ovirt-guest-agent/OVirtAgentLogic.py", line 173, in getTimezoneInfo
mag 22 06:08:28 docker.home python[3586]: return timezone.get_timezone_info()
mag 22 06:08:28 docker.home python[3586]: AttributeError: 'module' object has no attribute 'get_timezone_info'

Comment 1 Vinzenz Feenstra [evilissimo] 2016-05-23 07:08:55 UTC

*** This bug has been marked as a duplicate of bug 1337941 ***

Comment 2 Vinzenz Feenstra [evilissimo] 2016-05-23 07:12:22 UTC
*** Bug 1338518 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.