Bug 1338564 - Update fails with "AttributeError: 'Base' object has no attribute 'sigCheckPkg' (36)"
Update fails with "AttributeError: 'Base' object has no attribute 'sigCheckPk...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yumex-dnf (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
: Reopened
: 1339107 1340658 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-05-22 20:03 EDT by Vadim Raskhozhev
Modified: 2016-08-27 06:20 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-19 15:51:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vadim Raskhozhev 2016-05-22 20:03:58 EDT
Description of problem: an attemp to update with yumex-dnf ends with the following exception:

 EXCEPTION : g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.AttributeError: Traceback (most recent call last):
  File "/usr/lib64/python3.5/site-packages/dbus/service.py", line 707, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/python3.5/site-packages/dnfdaemon/server/__init__.py", line 83, in newFunc
    rc = func(*args, **kwargs)
  File "/usr/share/dnfdaemon/dnfdaemon-system", line 537, in RunTransaction
    result = self.run_transaction()
  File "/usr/lib/python3.5/site-packages/dnfdaemon/server/__init__.py", line 550, in run_transaction
    self._check_gpg_signatures(to_dnl)
  File "/usr/lib/python3.5/site-packages/dnfdaemon/server/__init__.py", line 699, in _check_gpg_signatures
    result, errmsg = self.base.sigCheckPkg(po)
  File "/usr/lib/python3.5/site-packages/dnf/util.py", line 79, in __getattr__
    % (C.__name__, name))
AttributeError: 'Base' object has no attribute 'sigCheckPkg'
 (36) 



Version-Release number of selected component (if applicable): yumex-dnf-4.3.3-1.fc24.noarch


How reproducible: always


Steps to Reproduce:
1. run yumex-dnf
2. select something to update and press 'Apply pending action'

Actual results: the abovementioned exception


Expected results: successful update
Comment 1 Christian Stadelmann 2016-05-23 14:14:23 EDT
Same here. I've reported a more detailled bug #1336102.
Comment 2 Christian Stadelmann 2016-05-23 14:30:39 EDT
Please ignore my previous comment #1.

Now the details:

Steps to reproduce:
1. open yumex-dnf
2. select any package for installation, e.g. python3-pylint-gui
3. press "run" button
4. confirm transaction
5. enter your password and confirm

What happens:
Crash on backend, error dialog shows up, transaction is aborted.

What should happen:
No crash. Transaction should be run.

Additional info:
Error message from yumex-dnf error dialog:

20:10:46: EXCEPTION : g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.AttributeError: Traceback (most recent call last):
  File "/usr/lib64/python3.5/site-packages/dbus/service.py", line 707, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/python3.5/site-packages/dnfdaemon/server/__init__.py", line 83, in newFunc
    rc = func(*args, **kwargs)
  File "/usr/share/dnfdaemon/dnfdaemon-system", line 537, in RunTransaction
    result = self.run_transaction()
  File "/usr/lib/python3.5/site-packages/dnfdaemon/server/__init__.py", line 550, in run_transaction
    self._check_gpg_signatures(to_dnl)
  File "/usr/lib/python3.5/site-packages/dnfdaemon/server/__init__.py", line 699, in _check_gpg_signatures
    result, errmsg = self.base.sigCheckPkg(po)
  File "/usr/lib/python3.5/site-packages/dnf/util.py", line 79, in __getattr__
    % (C.__name__, name))
AttributeError: 'Base' object has no attribute 'sigCheckPkg'
 (36)


Workaround:
downgrade dnf to 1.1.8, don't upgrade to 1.1.9.

Meta:
@timlau or Vadim Raskhozhev: can you please reassign this bug to dnf?
Comment 3 Tim Lauridsen 2016-05-25 03:56:08 EDT
the root cause is this commit

https://github.com/rpm-software-management/dnf/commit/f09c8699e431c3f1dd84418893226353bc8f595c#diff-d803a439b7caecec0dcb50c5d72b3b85L932

a mayor rename of all non API stuff in dnf.Base

This is not directly a dnf issues, because I use non public API and get hit by this, because DNF dont have any public API for signature checking.
Comment 4 Tim Lauridsen 2016-05-25 04:50:22 EDT
fixed upstream in dnf-daemmon
https://github.com/timlau/dnf-daemon/commit/d3e4d2d18cd579f8c269575152ca96dd439c8df5
Comment 5 Tim Lauridsen 2016-05-25 04:55:21 EDT
build a pre-release in copr

sudo dnf copr enable timlau/yumex-dnf
sudo dnf update dnfdaemon --refresh
Comment 6 Tim Lauridsen 2016-05-25 04:56:56 EDT
*** Bug 1339107 has been marked as a duplicate of this bug. ***
Comment 7 Tim Lauridsen 2016-05-25 08:35:40 EDT
the dnf issue triggered here is that the rename of the non public api methods
if not catched by the deprecation handler as many of the other

Base.xxxx to Base._xxxx renames

this is fixed in upstream dnf

https://github.com/rpm-software-management/dnf/commit/176a81e357b8e169008c831963c3b487b3bac40a

but it dont change the fact, that dnfdaemon is using non public API and it should not.
Comment 8 Woi 2016-05-25 14:20:59 EDT
Following your argument of comment #3: Is this really a bug of dnf-daemon or a bug of DNF because it's missing a public API for an important function?

However:
* This bug is critical for me, since I have set up some systems for non-technical users which use solely yumex-dnf for system-updates. 
* Fedora 23 is affected as well.
Comment 9 Veteran 2016-05-25 14:59:35 EDT
I also see this bug.

Doesn't affect command line dnf or yumex. Does affect yumex-dnf in fc23:
http://imgur.com/YXLW9vtl.png
Comment 10 antonio montagnani 2016-05-26 02:35:18 EDT
(In reply to Tim Lauridsen from comment #5)
> build a pre-release in copr
> 
> sudo dnf copr enable timlau/yumex-dnf
> sudo dnf update dnfdaemon --refresh

installed from copr, it works fine, but I would say that the option Svae repositories is not working, I mean that when I check/uncheck a repo, next time I start program, my choices were forgotten.Can you check please??
Comment 11 Tim Lauridsen 2016-05-26 06:31:54 EDT
> 
> installed from copr, it works fine, but I would say that the option Svae
> repositories is not working, I mean that when I check/uncheck a repo, next
> time I start program, my choices were forgotten.Can you check please??

https://github.com/timlau/yumex-dnf/issues/107
Comment 12 Fedora Update System 2016-05-26 06:47:43 EDT
dnfdaemon-0.3.16-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7d13699f3b
Comment 13 Fedora Update System 2016-05-26 06:47:51 EDT
dnfdaemon-0.3.16-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fe54f920b2
Comment 14 Veteran 2016-05-26 09:47:30 EDT
Thanks Tim, that fixed it on fc23 for me
Comment 15 Fedora Update System 2016-05-26 19:23:50 EDT
dnfdaemon-0.3.16-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7d13699f3b
Comment 16 Fedora Update System 2016-05-26 19:28:30 EDT
dnfdaemon-0.3.16-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fe54f920b2
Comment 17 Alex Villacís Lasso 2016-05-27 17:17:14 EDT
Confirming dnfdaemon-0.3.16-1.fc23 fixes the issue for me.
Comment 18 Fedora Update System 2016-05-27 22:23:12 EDT
dnfdaemon-0.3.16-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 19 Michael Mráka 2016-05-30 02:25:10 EDT
*** Bug 1340658 has been marked as a duplicate of this bug. ***
Comment 20 Fedora Update System 2016-05-30 17:21:31 EDT
dnfdaemon-0.3.16-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2016-08-18 11:18:59 EDT
dnf-1.1.10-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-267f843cda
Comment 22 Fedora Update System 2016-08-18 11:20:15 EDT
dnf-1.1.10-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8caa619a9e
Comment 23 Fedora Update System 2016-08-18 11:21:18 EDT
dnf-1.1.10-1.fc24 dnf-plugins-core-0.1.21-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-878284e0d3
Comment 24 Fedora Update System 2016-08-18 12:52:30 EDT
dnf-1.1.10-1.fc25, dnf-plugins-core-0.1.21-4.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8caa619a9e
Comment 25 Fedora Update System 2016-08-18 20:22:18 EDT
dnf-1.1.10-1.fc23, dnf-plugins-core-0.1.21-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-267f843cda
Comment 26 Fedora Update System 2016-08-18 20:57:31 EDT
dnf-1.1.10-1.fc24, dnf-plugins-core-0.1.21-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-878284e0d3
Comment 27 Fedora Update System 2016-08-19 15:50:24 EDT
dnf-1.1.10-1.fc24, dnf-plugins-core-0.1.21-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 28 Fedora Update System 2016-08-23 11:19:30 EDT
dnf-1.1.10-1.fc23, dnf-plugins-core-0.1.21-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 29 Fedora Update System 2016-08-27 06:20:28 EDT
dnf-1.1.10-1.fc25, dnf-plugins-core-0.1.21-4.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.