Bug 1339107 - Error during installation
Summary: Error during installation
Keywords:
Status: CLOSED DUPLICATE of bug 1338564
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex-dnf
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-24 07:38 UTC by antonio montagnani
Modified: 2016-05-25 08:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-25 08:56:56 UTC
Type: Bug


Attachments (Terms of Use)

Description antonio montagnani 2016-05-24 07:38:20 UTC
Description of problem:
Since last updates no way to use graphical interface

Version-Release number of selected component (if applicable):
yumex-dnf-4.1.6-1.fc23.noarch

How reproducible:
always

Steps to Reproduce:
1.just run yumx-dnf and try to install/update

2.
3.

Actual results:
g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.AttributeError: Traceback (most recent call last):
  File "/usr/lib64/python3.4/site-packages/dbus/service.py", line 707, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/python3.4/site-packages/dnfdaemon/server/__init__.py", line 83, in newFunc
    rc = func(*args, **kwargs)
  File "/usr/share/dnfdaemon/dnfdaemon-system", line 537, in RunTransaction
    result = self.run_transaction()
  File "/usr/lib/python3.4/site-packages/dnfdaemon/server/__init__.py", line 564, in run_transaction
    self._check_gpg_signatures(to_dnl)
  File "/usr/lib/python3.4/site-packages/dnfdaemon/server/__init__.py", line 713, in _check_gpg_signatures
    result, errmsg = self.base.sigCheckPkg(po)
  File "/usr/lib/python3.4/site-packages/dnf/util.py", line 79, in __getattr__
    % (C.__name__, name))
AttributeError: 'Base' object has no attribute 'sigCheckPkg'
 (36)

Expected results:
standard upgrade/installation

Additional info:
dnf from a terminal works great

Comment 1 antonio montagnani 2016-05-24 08:18:52 UTC
I assume that there is some misalignment between dnf and yumex-dnf as I upgraded another system just now by graphical interface, but after upgrading dnf and related packages, restarting graphical interface I could reproduce same bug

Comment 2 Tim Lauridsen 2016-05-25 08:56:56 UTC

*** This bug has been marked as a duplicate of bug 1338564 ***


Note You need to log in before you can comment on or make changes to this bug.