Bug 1338634 - AFR : fuse,nfs mount hangs when directories with same names are created and deleted continuously
Summary: AFR : fuse,nfs mount hangs when directories with same names are created and d...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Satish Mohan
QA Contact:
URL:
Whiteboard: triaged
Depends On: 951195 986916 1115367 1262680 1266834 1266836 1286582
Blocks: 1121920 1338668 1338669
TreeView+ depends on / blocked
 
Reported: 2016-05-23 07:42 UTC by Sakshi
Modified: 2017-03-27 18:16 UTC (History)
17 users (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1286582
: 1338668 1338669 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:16:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Sakshi 2016-05-23 07:42:42 UTC
+++ This bug was initially created as a clone of Bug #1286582 +++

+++ This bug was initially created as a clone of Bug #986916 +++

Description of problem:
=========================
In a distribute-replicate volume, when directories with same names are created and deleted continuously on fuse and nfs mount points, after certain time the mount points hang. 



How reproducible:

test_bug_922792.sh
===================
#!/bin/bash

dir=$(dirname $(readlink -f $0))
echo 'Script in '$dir
while :
do
        mkdir -p foo$1/bar/gee
        mkdir -p foo$1/bar/gne
        mkdir -p foo$1/lna/gme
        rm -rf foo$1
done

Steps to Reproduce:
===================
1. Create a distribute-replicate volume ( 6 x 2 ). 4 storage nodes . 3 bricks on each storage node. 

2. Start the volume.

3. Create 2 fuse and 2 nfs mounts on each RHEL5.9 and RHEL6.4 clients. 

4. From all the mount points execute: "test_bug_922792.sh" 

Actual results:
===============
After sometime, fuse and nfs mount hangs. 

Expected results:
================
Fuse and nfs mount shouldn't hang.

Comment 1 Vijay Bellur 2016-05-23 08:32:17 UTC
REVIEW: http://review.gluster.org/14496 (dht: selfheal should wind mkdir call to subvols with ESTALE error) posted (#1) for review on master by Sakshi Bansal

Comment 2 Vijay Bellur 2016-05-25 14:22:19 UTC
COMMIT: http://review.gluster.org/14496 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit ce466fa6353394a6ac4ca9922237de77686d64d0
Author: Sakshi Bansal <sabansal@redhat.com>
Date:   Fri May 20 15:16:17 2016 +0530

    dht: selfheal should wind mkdir call to subvols with ESTALE error
    
    Change-Id: I7140e50263b5f28b900829592c664fa1d79f3f99
    BUG: 1338634
    Signed-off-by: Sakshi Bansal <sabansal@redhat.com>
    Reviewed-on: http://review.gluster.org/14496
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 5 Shyamsundar 2017-03-27 18:16:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.