Bug 1338669 - AFR : fuse,nfs mount hangs when directories with same names are created and deleted continuously
Summary: AFR : fuse,nfs mount hangs when directories with same names are created and d...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: 3.8.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Sakshi
QA Contact:
URL:
Whiteboard: triaged
Depends On: 951195 986916 1115367 1262680 1266834 1266836 1286582 1338634
Blocks: 1121920 1299184 1338668
TreeView+ depends on / blocked
 
Reported: 2016-05-23 08:36 UTC by Sakshi
Modified: 2016-06-16 12:32 UTC (History)
17 users (show)

Fixed In Version: glusterfs-3.8.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1338634
Environment:
Last Closed: 2016-06-16 12:32:10 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Sakshi 2016-05-23 08:36:22 UTC
+++ This bug was initially created as a clone of Bug #1338634 +++

+++ This bug was initially created as a clone of Bug #1286582 +++

+++ This bug was initially created as a clone of Bug #986916 +++

Description of problem:
=========================
In a distribute-replicate volume, when directories with same names are created and deleted continuously on fuse and nfs mount points, after certain time the mount points hang. 



How reproducible:

test_bug_922792.sh
===================
#!/bin/bash

dir=$(dirname $(readlink -f $0))
echo 'Script in '$dir
while :
do
        mkdir -p foo$1/bar/gee
        mkdir -p foo$1/bar/gne
        mkdir -p foo$1/lna/gme
        rm -rf foo$1
done

Steps to Reproduce:
===================
1. Create a distribute-replicate volume ( 6 x 2 ). 4 storage nodes . 3 bricks on each storage node. 

2. Start the volume.

3. Create 2 fuse and 2 nfs mounts on each RHEL5.9 and RHEL6.4 clients. 

4. From all the mount points execute: "test_bug_922792.sh" 

Actual results:
===============
After sometime, fuse and nfs mount hangs. 

Expected results:
================
Fuse and nfs mount shouldn't hang.

--- Additional comment from Vijay Bellur on 2016-05-23 04:32:17 EDT ---

REVIEW: http://review.gluster.org/14496 (dht: selfheal should wind mkdir call to subvols with ESTALE error) posted (#1) for review on master by Sakshi Bansal

Comment 1 Vijay Bellur 2016-05-23 08:45:27 UTC
REVIEW: http://review.gluster.org/14500 (dht: selfheal should wind mkdir call to subvols with ESTALE error) posted (#1) for review on release-3.8 by Sakshi Bansal

Comment 2 Vijay Bellur 2016-05-27 03:37:10 UTC
COMMIT: http://review.gluster.org/14500 committed in release-3.8 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 57d686204c3f71bb6b3aa2383949e4c9b9738059
Author: Sakshi Bansal <sabansal@redhat.com>
Date:   Fri May 20 15:16:17 2016 +0530

    dht: selfheal should wind mkdir call to subvols with ESTALE error
    
    Backport of http://review.gluster.org/#/c/14496/
    
    > Change-Id: I7140e50263b5f28b900829592c664fa1d79f3f99
    > BUG: 1338634
    > Signed-off-by: Sakshi Bansal <sabansal@redhat.com>
    
    Change-Id: I7140e50263b5f28b900829592c664fa1d79f3f99
    BUG: 1338669
    Signed-off-by: Sakshi Bansal <sabansal@redhat.com>
    Reviewed-on: http://review.gluster.org/14500
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 3 Niels de Vos 2016-06-16 12:32:10 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.