Bug 133877 - locale problem with redhat-config-printer
locale problem with redhat-config-printer
Status: CLOSED DUPLICATE of bug 131563
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-printer (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-28 03:18 EDT by dhe
Modified: 2014-10-19 19:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dhe 2004-09-28 03:18:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; zh-CN; rv:1.4.3)
Gecko/20040803

Description of problem:
The redhat-config-printer crashed when the default language is
Simplified Chinese or Traditional Chinese. 



Version-Release number of selected component (if applicable):
redhat-config-printer-0.6.47.3.19

How reproducible:
Always

Steps to Reproduce:
1. env | grep LANG LANG=zh_CN.GB2312
2. redhat-config-printer
3.
    
#redhat-config-printer
Actual Results:  Traceback (most recent call last):
  File "/usr/sbin/redhat-config-printer", line 9, in ?
    import queueTree
  File "/usr/share/printconf/util/queueTree.py", line 945, in ?
    queueTree()
  File "/usr/share/printconf/util/queueTree.py", line 102, in __init__
    if cups_import.import_needed ():
  File "/usr/share/printconf/util/cups_import.py", line 200, in
import_needed
    which = which_spooler ()
  File "/usr/share/printconf/util/cups_import.py", line 195, in
which_spooler
    return which
UnboundLocalError: local variable 'which' referenced before assignment

Additional info:

As Kazunori Fukushige( kfukushi@redhat.com ) tested, this problem also
happens on the system where either Japanese, Korean, French or German
is configured as the default lauguage.

Current solution: 
Set:  LANG=C
This problem doesn't happen any more.
 ( tested by Martin C. Messer  marty@redhat.com)
Comment 1 Tim Waugh 2004-09-28 04:38:09 EDT

*** This bug has been marked as a duplicate of 131563 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:57 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.