Bug 133894 - libmusicbrainz-devel should include the .so file.
libmusicbrainz-devel should include the .so file.
Status: CLOSED DUPLICATE of bug 133306
Product: Fedora
Classification: Fedora
Component: libmusicbrainz (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-09-28 06:55 EDT by Aurelien Bompard
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aurelien Bompard 2004-09-28 06:55:45 EDT
Description of problem:

The -devel subpackage should include /usr/lib/libmusicbrainz.so

Version-Release number of selected component (if applicable):
2.0.2-7.1

How reproducible:
N/A

To package libtunepimp (http://musicbrainz.org), I need to do a
ln -s libmusicbrainz.so.4.0.0 /usr/lib/libmusicbrainz.so
for the configure to pick up libmusicbrainz.
Comment 1 Colin Walters 2004-09-29 01:11:56 EDT
It's true that the -devel package should include the .so symlink,
instead of libmusicbrainz itself.  I fixed that bug.

However that's not the bug you're running into.  The problem you are
having is because we ship libmusicbrainz 2.0, and tunepimp apparently
requires 2.1.  There is an open bug to package the 2.1 series, but I
can't simply upgrade the libmusicbrainz package to it because they
changed soname.

If creating a symlink actually *works* then that implies that they
didn't change ABI, which makes me wonder why they bumped the soname.



*** This bug has been marked as a duplicate of 133306 ***
Comment 2 Aurelien Bompard 2004-09-29 02:53:32 EDT
It does not build, I get this error :
-----------
filelookup.cpp: In member function `int
LookupFile::extractAlbumList(void*)':
filelookup.cpp:117: error: `MBE_AlbumGetNumReleaseDates' undeclared
(first use this function)
filelookup.cpp:117: error: (Each undeclared identifier is reported
only once for each function it appears in.)
filelookup.cpp:121: error: `MBS_SelectReleaseDate' undeclared (first
use this function)
filelookup.cpp:124: error: `MBE_ReleaseGetDate' undeclared (first use
this function)
filelookup.cpp:139: error: `MBE_ReleaseGetCountry' undeclared (first
use this function)
-----------

But without the .so file, it would not pass ./configure.
Comment 3 Red Hat Bugzilla 2006-02-21 14:05:57 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.