Bug 133901 - cryptoloop kernel module missing
cryptoloop kernel module missing
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Burke
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-28 08:35 EDT by Need Real Name
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:17:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-09-28 08:35:01 EDT
Description of problem:  cryptoloop modules missing from the errata
kernel.  Also when attempting to compile the cryptoloop option into
the latest kernel release, the make oldconfig strips the
CONFIG_CRYPTOLOOP=m from the Makefile.


Version-Release number of selected component (if applicable):


How reproducible:  Everytime.   RH support was also able to reproduce. 


Steps to Reproduce:
1.  If running 2.4.21-20.EL errata kernel simply try "modprobe cryptoloop"

2.  If trying to compile the kernel.

   a) vi Makefile;#(editing line 4, as they taught me in my RHCE 
Fastrack course);cp -p configs/kernel-2.4.21-i686.config .config
   b) Look at the before and after picture of the .config file looking
for CONFIG_CRYPTOLOOP=m, then again after "make oldconfig"
  
Actual results:  cryptoloop gets stripped from the make.


Expected results:  cryptoloop and other crypto options available to
xconfig and to errata kernel.  Supported or not, the options should
still be available.


Additional info:

If you try to skip the make oldconfig the make will fail when trying
to "make bzImage" with the following:

/usr/src/linux-2.4.21-20.EL/include/net/ah.h: In function
`ah_hmac_digest': 
/usr/src/linux-2.4.21-20.EL/include/net/ah.h:26: warning: implicit
declaration 
of function `crypto_hma c_init' 
/usr/src/linux-2.4.21-20.EL/include/net/ah.h:27: `crypto_hmac_update'
undeclared 
(first use in this fu nction) 
/usr/src/linux-2.4.21-20.EL/include/net/ah.h:27: (Each undeclared
identifier is 
reported only once 
/usr/src/linux-2.4.21-20.EL/include/net/ah.h:27: for each function it
appears 
in.) 
/usr/src/linux-2.4.21-20.EL/include/net/ah.h:28: warning: implicit
declaration 
of function `crypto_hma c_final' 
In file included from xfrm_algo.c:19: 
/usr/src/linux-2.4.21-20.EL/include/net/esp.h: In function
`esp_hmac_digest': 
/usr/src/linux-2.4.21-20.EL/include/net/esp.h:49: `crypto_hmac_update' 
undeclared (first use in this f unction)
Comment 1 Arjan van de Ven 2004-09-28 16:25:10 EDT
I think you're confused; cryptoloop never was part of rhel3.
Comment 2 Ernie Petrides 2004-09-28 22:04:44 EDT
To the bug reporter, did you intend this to be a request for
a new feature of RHEL3?  I see that drivers/crypto is in the
unsupported modules list, and I don't see any associated code
for cryptoloop.

Also, I think this might be a dup of bug 128011.
Comment 3 Need Real Name 2004-09-29 08:17:05 EDT
Looked at reported 128011.  The problem is similar.  When I searched
for bugs initially, nothing came up on my search.

Also looked at other comments sent to me.   Did not know I was asking
for a new feature.  I believe the cryptoloop module was part of older
versions of RH Linux, and other versions of Linux.

Unsupported means that if I have questions about a feature, you won't
help.  Unsupported does not necessarily mean that a feature should be
taken away then pronounced unsupported.


If the feature is not supported in RH Enterprise 3, then our
conversation is apparently done.

However, if you concider the feature simply missing from the release,
then we still have room for discussion.

I would, however, like to know the justification for non-support. 
Security concerns?  See "http://lwn.net/Articles/67216/"


Sincerely,


Stanley Hornyak
Senior Unix System Administrator
NICHD Unix Support
Red Hat Certified Engineer (7.2)
Sun Certified Solaris Administrator (Ver 7)
Comment 4 Rik van Riel 2004-09-29 09:07:48 EDT
Crypto loop would seem like a reasonable feature request. Reassigning
to the managers who deal with feature requests ;)
Comment 5 Need Real Name 2005-04-05 13:14:49 EDT
Looks like the original ticket I put in, thanks.
Comment 6 RHEL Product and Program Management 2007-10-19 15:17:26 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.