Bug 1339516 - Can not paste in terminal on IE11/Edge25 and Firefox46
Summary: Can not paste in terminal on IE11/Edge25 and Firefox46
Keywords:
Status: CLOSED DUPLICATE of bug 1278733
Alias: None
Product: OKD
Classification: Red Hat
Component: Management Console
Version: 3.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Jessica Forrester
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-25 08:39 UTC by Yanping Zhang
Modified: 2016-05-25 13:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-25 13:31:30 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yanping Zhang 2016-05-25 08:39:48 UTC
Description of problem:
Create a pod in project, then try to copy/paste something in the terminal of the pod on web console, it succeeds to paste in the terminal on Chrome50 and Safari9, but failed to paste in the terminal on IE11/Edge25 and Firefox46.

Version-Release number of selected component (if applicable):
openshift version
openshift v1.3.0-alpha.0-669-g6e74aa4
kubernetes v1.3.0-alpha.1-331-g0522e63
etcd 2.3.0


How reproducible:
Always

Steps to Reproduce:
1.Create a pod in project.
$oc run testpod --image=aosqe/hello-openshift --generator=run-pod/v1 -n project1
2.Try to copy/paste something in the terminal of the pod on web console
3.

Actual results:
2.Could not paste in terminal successfully on IE11/Edge25 and Firefox46.

Expected results:
2.Should succeed to paste in terminal on all browsers.

Additional info:

Comment 1 Jessica Forrester 2016-05-25 13:31:30 UTC
Known limitation for now, the browser terminal component we depend on has poor support for copy/paste.

*** This bug has been marked as a duplicate of bug 1278733 ***


Note You need to log in before you can comment on or make changes to this bug.