Bug 1278733 - Pods Terminal tab should support copy/paste text
Summary: Pods Terminal tab should support copy/paste text
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.1.0
Hardware: Unspecified
OS: Linux
high
low
Target Milestone: ---
: 3.10.0
Assignee: Jessica Forrester
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1339516 1477132 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-11-06 10:18 UTC by Libor Fuka
Modified: 2018-07-30 19:09 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Copy and paste in the web console container terminal did not work properly on Firefox and Internet Explorer. This has been fixed. You can now copy and fix from the context menu or using keyboard shortcuts.
Clone Of:
Environment:
Last Closed: 2018-07-30 19:08:59 UTC


Attachments (Terms of Use)
FF_on_Fedora_terminal_copy_paste_issue (527.35 KB, application/octet-stream)
2017-09-20 10:07 UTC, Xingxing Xia
no flags Details
FF_on_Windows10_terminal_copy_paste_issue (613.11 KB, application/octet-stream)
2017-09-20 10:08 UTC, Xingxing Xia
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:09:27 UTC

Description Libor Fuka 2015-11-06 10:18:06 UTC
Description of problem:
I can not copy/paste from/to Pods Terminal tab.

Version-Release number of selected component (if applicable):
3.1.0

How reproducible:
Always

Expected results:
Copy/paste should work

Additional info:
Firefox 37.0.2

Comment 1 Jessica Forrester 2015-11-06 16:38:17 UTC
Using the right click menu works in Chrome/Safari.  Will need to investigate why right click menu doesn't work on firefox and IE.

term.js has different keyboard shortcuts for copy/paste because of selection modes, see https://github.com/chjj/term.js/#tmux-like

We probably need to add a help tooltip somewhere about the keyboard shortcut thing because that's unexpected behavior.

Comment 2 Jessica Forrester 2015-11-06 21:22:15 UTC
Stef why are we locking to term.js 0.0.3?

Comment 3 Stef Walter 2015-11-09 08:28:21 UTC
0.0.3 was tested with Cockpit. But we can try out later versions and bump the version.

I would suggest that we try and contribute Ctrl-Shift-C and Ctrl-Shift-V upstream as keyboard shortcuts, if we can make them work.

Comment 4 Jessica Forrester 2015-12-21 20:32:12 UTC
Took a quick look and apparently the bower version of term.js is a fork of the actual term.js repo and is missing the latest several versions.  I opened an issue to the main repo to see if they are willing to resolve it and take over maintenance.  https://github.com/chjj/term.js/issues/103

Comment 5 Jessica Forrester 2016-05-25 13:31:30 UTC
*** Bug 1339516 has been marked as a duplicate of this bug. ***

Comment 10 Xingxing Xia 2017-09-20 10:05:50 UTC
(In reply to shahan from comment #9)
> This bug has been fixed in the https://trello.com/c/zoxUAO2w, Tested this on
> all related browers, could copy/paste text in the pod terminal.
>  OpenShift Master:v3.6.0-rc.0+01e5a1b-550
> QE could verify when it's changed to ON_QA.
Please ignore this. See below

(In reply to Jessica Forrester from comment #1)
> Using the right click menu works in Chrome/Safari.  Will need to investigate
> why right click menu doesn't work on firefox and IE.
In my check on v3.7.0-0.126.4, I checked right click menu in terminal on FF (latest 55.0.3), IE (version 11.608.15063.0), Edge, Chrome.
IE now can show Copy/Paste on right click menu in terminal and Copy/Paste work.

But FF still has problem. And FF copy/paste behavior differs on Fedora and Windows 10:
On Windows 10 FF, the terminal right click does not show Copy/Paste at all
On Fedora FF:
  when terminal text is not selected, it can show Copy/Paste, the Paste works, but the Copy is also shown, which should be gray disabled or not shown.
  when terminal text is selected, it cannot show Copy, which should be shown.

See screenshots

Comment 11 Xingxing Xia 2017-09-20 10:07:46 UTC
Created attachment 1328362 [details]
FF_on_Fedora_terminal_copy_paste_issue

Comment 12 Xingxing Xia 2017-09-20 10:08:27 UTC
Created attachment 1328363 [details]
FF_on_Windows10_terminal_copy_paste_issue

Comment 13 Xingxing Xia 2017-09-20 10:12:01 UTC
(In reply to Xingxing Xia from comment #10)
> See screenshots
Typo. Should be video records

Comment 14 Samuel Padgett 2017-09-20 12:02:50 UTC
Opened upstream xterm.js issue:

https://github.com/sourcelair/xterm.js/issues/1003

Comment 15 Jessica Forrester 2017-11-01 18:02:40 UTC
*** Bug 1477132 has been marked as a duplicate of this bug. ***

Comment 16 Jessica Forrester 2017-11-01 18:03:40 UTC
This also affects the debug terminal since its the same xterm.js component being used.

Comment 18 shahan 2018-01-08 01:57:59 UTC
Seems this fix PR still not merge. https://github.com/openshift/origin-web-console/issues/2531. Samuel, could you help set the right target release?

Comment 20 Robb Hamilton 2018-03-01 21:58:30 UTC
PR to resolve:  https://github.com/openshift/origin-web-console/pull/2860

It bumps xterm.js to v3.1.0

Comment 22 shahan 2018-04-02 02:08:35 UTC
Could we change to ON_QA now? QE could verify on time when it's changed to ON_QA.

Comment 23 shahan 2018-04-11 03:04:00 UTC
@all move this to verify since it has been fixed for a long time and will accept related trello card. Thx.

Comment 25 errata-xmlrpc 2018-07-30 19:08:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.