Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1339602 - [ja_JP] Translations are missing in 'Compute'-'Infrastructure' menu and its sub menu pages
Summary: [ja_JP] Translations are missing in 'Compute'-'Infrastructure' menu and its s...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: GA
: 5.8.0
Assignee: Milan Zázrivec
QA Contact: Krishna Babu K
URL:
Whiteboard: i18n
Depends On:
Blocks: 1391748
TreeView+ depends on / blocked
 
Reported: 2016-05-25 12:28 UTC by Krishna Babu K
Modified: 2017-08-30 02:39 UTC (History)
10 users (show)

Fixed In Version: 5.8.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1391748 (view as bug list)
Environment:
Last Closed: 2017-06-12 17:37:09 UTC
Category: Bug
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
Screen shot reference for the reported issue. (441.50 KB, application/x-tar)
2016-05-25 12:28 UTC, Krishna Babu K
no flags Details

Description Krishna Babu K 2016-05-25 12:28:55 UTC
Created attachment 1161397 [details]
Screen shot reference for the reported issue.

Description of problem:
  Translations are missing in cfme under 'Compute'-'Infrastructure' menu and its corresponding pages for ja_JP locale.

Version-Release number of selected component (if applicable):
   5.6.0.7-beta2.6

How reproducible:
  Always

Steps to Reproduce:
  Login to CFME with ja_JP locale.
  1. Navigate to 'Compute'-'Infrastructure'-'Providers' and select any provider 
     from right side pane, click on 'Configuration' drop down menu.
     The "Configuration" drop-down menu items have a mixture of English and 
     Japanese strings such as:
     "Discover インフラストラクチャープロバイダー"
     "Add a インフラストラクチャープロバイダー"

  2. Navigate to 'Compute'-'Infrastructure'-'Providers' and click any provider 
     from right side pane.
     The page after clicking any provider has a chart where some English items 
     remain such as:
     'Type', 'VMs and Instances', 'Templates'

  3. Navigate to 'Compute'-'Infrastructure'-'Clusters' and click on any cluster
     The page after clicking any cluster has a chart where some item remains in
     English, such as "Aggregate disk capacity".

  4. Navigate to 'Compute'-'Infrastructure'-'PXE'-'Customization Templates'.
     "All Customization Templates" on the left side pane remains in English. 
     
Actual results:
  Translations are missing.

Expected results:
  Translations should be available.

Additional info:
  Screenshot references attached.

Comment 2 Milan Zázrivec 2016-06-02 12:24:20 UTC
Untranslated strings (as in we need another trans. cycle for this to be fixed).

Comment 3 Milan Zázrivec 2016-10-25 13:26:17 UTC
Moving to POST, since latest translations have been merged.

Comment 4 Krishna Babu K 2016-10-26 12:19:05 UTC
Tested on Version 5.7.0.7-beta1.20161025153249_9376fbd
The 2nd issue reported in the description is still reproducible.
The following entries are not localized since they are not available for localization:
"Type"
"VMs and Instances"
"Templates"

Comment 6 Krishna Babu K 2017-02-07 15:28:09 UTC
Verified on 5.8.0.0.20170201144150_848e68b 
Could not reproduce the issue described in Comment 4, since UI changed in this version.


Note You need to log in before you can comment on or make changes to this bug.