Bug 1339701 - AttributeError: 'NoneType' object has no attribute 'mountpoints'
Summary: AttributeError: 'NoneType' object has no attribute 'mountpoints'
Status: CLOSED DUPLICATE of bug 1304480
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 23
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:9b093da87c3ce7c1ae3f7071481...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-25 16:13 UTC by velko85
Modified: 2016-05-25 18:31 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-25 16:15:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (2.49 MB, text/plain)
2016-05-25 16:14 UTC, velko85
no flags Details
File: anaconda.log (14.01 KB, text/plain)
2016-05-25 16:14 UTC, velko85
no flags Details
File: dnf.log (7.35 KB, text/plain)
2016-05-25 16:14 UTC, velko85
no flags Details
File: dnf.rpm.log (147 bytes, text/plain)
2016-05-25 16:15 UTC, velko85
no flags Details
File: environ (3.21 KB, text/plain)
2016-05-25 16:15 UTC, velko85
no flags Details
File: journalctl (512.30 KB, text/plain)
2016-05-25 16:15 UTC, velko85
no flags Details
File: lsblk_output (881 bytes, text/plain)
2016-05-25 16:15 UTC, velko85
no flags Details
File: nmcli_dev_list (2.18 KB, text/plain)
2016-05-25 16:15 UTC, velko85
no flags Details
File: os_info (518 bytes, text/plain)
2016-05-25 16:15 UTC, velko85
no flags Details
File: program.log (1.83 MB, text/plain)
2016-05-25 16:15 UTC, velko85
no flags Details
File: storage.log (56.65 KB, text/plain)
2016-05-25 16:15 UTC, velko85
no flags Details
File: ifcfg.log (4.91 KB, text/plain)
2016-05-25 16:15 UTC, velko85
no flags Details
File: packaging.log (285 bytes, text/plain)
2016-05-25 16:15 UTC, velko85
no flags Details

Description velko85 2016-05-25 16:13:53 UTC
Version-Release number of selected component:
anaconda-core-23.19.10-1.fc23.i686

The following was filed automatically by anaconda:
anaconda 23.19.10-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.4/site-packages/pyanaconda/packaging/dnfpayload.py", line 550, in spaceRequired
    for (key, val) in self.storage.mountpoints.items():
  File "/usr/lib/python3.4/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 817, in _check_space_and_get_dialog
    required_space = self.payload.spaceRequired
  File "/usr/lib/python3.4/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 964, in on_back_clicked
    dialog = self._check_space_and_get_dialog(disks)
AttributeError: 'NoneType' object has no attribute 'mountpoints'

Additional info:
cmdline:        /usr/bin/python3  /usr/sbin/anaconda
cmdline_file:   BOOT_IMAGE=/vmlinuz-4.5.4-200.fc23.i686 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet LANG=en_US.UTF-8
executable:     /usr/sbin/anaconda
hashmarkername: anaconda
kernel:         4.5.4-200.fc23.i686
other involved packages: anaconda-gui-23.19.10-1.fc23.i686
product:        Fedora
release:        Fedora release 23 (Twenty Three)
type:           anaconda
version:        23

This is a private, duplicate bug report of bug 1304480. The report has been created because Bugzilla cannot grant access to a comment for a specific group.

Comment 1 velko85 2016-05-25 16:14:55 UTC
Created attachment 1161512 [details]
File: anaconda-tb

Comment 2 velko85 2016-05-25 16:14:57 UTC
Created attachment 1161513 [details]
File: anaconda.log

Comment 3 velko85 2016-05-25 16:14:59 UTC
Created attachment 1161514 [details]
File: dnf.log

Comment 4 velko85 2016-05-25 16:15:00 UTC
Created attachment 1161515 [details]
File: dnf.rpm.log

Comment 5 velko85 2016-05-25 16:15:02 UTC
Created attachment 1161516 [details]
File: environ

Comment 6 velko85 2016-05-25 16:15:08 UTC
Created attachment 1161517 [details]
File: journalctl

Comment 7 velko85 2016-05-25 16:15:09 UTC
Created attachment 1161518 [details]
File: lsblk_output

Comment 8 velko85 2016-05-25 16:15:11 UTC
Created attachment 1161519 [details]
File: nmcli_dev_list

Comment 9 velko85 2016-05-25 16:15:13 UTC
Created attachment 1161520 [details]
File: os_info

Comment 10 velko85 2016-05-25 16:15:27 UTC
Created attachment 1161521 [details]
File: program.log

Comment 11 velko85 2016-05-25 16:15:31 UTC
Created attachment 1161522 [details]
File: storage.log

Comment 12 velko85 2016-05-25 16:15:33 UTC
Created attachment 1161523 [details]
File: ifcfg.log

Comment 13 velko85 2016-05-25 16:15:35 UTC
Created attachment 1161524 [details]
File: packaging.log

Comment 14 velko85 2016-05-25 16:15:37 UTC

*** This bug has been marked as a duplicate of bug 1304480 ***


Note You need to log in before you can comment on or make changes to this bug.