Bug 1304480 - AttributeError: 'NoneType' object has no attribute 'mountpoints'
AttributeError: 'NoneType' object has no attribute 'mountpoints'
Status: CLOSED DUPLICATE of bug 1271657
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
abrt_hash:9b093da87c3ce7c1ae3f7071481...
:
: 1339701 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-03 13:14 EST by Peter Gervase
Modified: 2016-05-25 12:15 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-25 04:12:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (355.43 KB, text/plain)
2016-02-03 13:14 EST, Peter Gervase
no flags Details
File: anaconda.log (12.19 KB, text/plain)
2016-02-03 13:14 EST, Peter Gervase
no flags Details
File: dnf.log (1.05 KB, text/plain)
2016-02-03 13:14 EST, Peter Gervase
no flags Details
File: dnf.rpm.log (147 bytes, text/plain)
2016-02-03 13:14 EST, Peter Gervase
no flags Details
File: environ (459 bytes, text/plain)
2016-02-03 13:14 EST, Peter Gervase
no flags Details
File: lsblk_output (2.82 KB, text/plain)
2016-02-03 13:14 EST, Peter Gervase
no flags Details
File: nmcli_dev_list (1.77 KB, text/plain)
2016-02-03 13:14 EST, Peter Gervase
no flags Details
File: os_info (451 bytes, text/plain)
2016-02-03 13:14 EST, Peter Gervase
no flags Details
File: program.log (69.41 KB, text/plain)
2016-02-03 13:14 EST, Peter Gervase
no flags Details
File: storage.log (86.00 KB, text/plain)
2016-02-03 13:14 EST, Peter Gervase
no flags Details
File: syslog (112.67 KB, text/plain)
2016-02-03 13:15 EST, Peter Gervase
no flags Details
File: ifcfg.log (2.57 KB, text/plain)
2016-02-03 13:15 EST, Peter Gervase
no flags Details
File: packaging.log (1.13 KB, text/plain)
2016-02-03 13:15 EST, Peter Gervase
no flags Details

  None (edit)
Description Peter Gervase 2016-02-03 13:14:39 EST
Description of problem:
I booted off a usb thumb drive for installing Fedora. I hit OK on the initial screen. I plugged in an ethernet cable, then clicked on partitioning, then clicked Done to use the default partitioning. It was when I clicked Done that I hit this error.

Version-Release number of selected component:
anaconda-23.19.10-1

The following was filed automatically by anaconda:
anaconda 23.19.10-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.4/site-packages/pyanaconda/packaging/dnfpayload.py", line 550, in spaceRequired
    for (key, val) in self.storage.mountpoints.items():
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 817, in _check_space_and_get_dialog
    required_space = self.payload.spaceRequired
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 964, in on_back_clicked
    dialog = self._check_space_and_get_dialog(disks)
AttributeError: 'NoneType' object has no attribute 'mountpoints'

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-WS-23-x86_64 quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.3-300.fc23.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        23
Comment 1 Peter Gervase 2016-02-03 13:14:46 EST
Created attachment 1120877 [details]
File: anaconda-tb
Comment 2 Peter Gervase 2016-02-03 13:14:47 EST
Created attachment 1120878 [details]
File: anaconda.log
Comment 3 Peter Gervase 2016-02-03 13:14:49 EST
Created attachment 1120879 [details]
File: dnf.log
Comment 4 Peter Gervase 2016-02-03 13:14:50 EST
Created attachment 1120880 [details]
File: dnf.rpm.log
Comment 5 Peter Gervase 2016-02-03 13:14:51 EST
Created attachment 1120881 [details]
File: environ
Comment 6 Peter Gervase 2016-02-03 13:14:53 EST
Created attachment 1120882 [details]
File: lsblk_output
Comment 7 Peter Gervase 2016-02-03 13:14:54 EST
Created attachment 1120883 [details]
File: nmcli_dev_list
Comment 8 Peter Gervase 2016-02-03 13:14:55 EST
Created attachment 1120884 [details]
File: os_info
Comment 9 Peter Gervase 2016-02-03 13:14:57 EST
Created attachment 1120885 [details]
File: program.log
Comment 10 Peter Gervase 2016-02-03 13:14:59 EST
Created attachment 1120886 [details]
File: storage.log
Comment 11 Peter Gervase 2016-02-03 13:15:01 EST
Created attachment 1120887 [details]
File: syslog
Comment 12 Peter Gervase 2016-02-03 13:15:02 EST
Created attachment 1120888 [details]
File: ifcfg.log
Comment 13 Peter Gervase 2016-02-03 13:15:03 EST
Created attachment 1120889 [details]
File: packaging.log
Comment 14 Alexander Todorov 2016-02-25 04:12:58 EST

*** This bug has been marked as a duplicate of bug 1271657 ***
Comment 15 velko85 2016-05-25 12:15:37 EDT
*** Bug 1339701 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.