Bug 1339742 - A package is missing when trying to #dnf groupinstall 'Basic Desktop'
A package is missing when trying to #dnf groupinstall 'Basic Desktop'
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Stephen Gallagher
:
: 1340059 (view as bug list)
Depends On: 1337731
Blocks:
  Show dependency treegraph
 
Reported: 2016-05-25 14:21 EDT by dsavov
Modified: 2016-07-21 11:07 EDT (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-20 11:25:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
console screenshot (15.75 KB, image/png)
2016-05-25 14:21 EDT, dsavov
no flags Details

  None (edit)
Description dsavov 2016-05-25 14:21:24 EDT
Created attachment 1161561 [details]
console screenshot

Description of problem:
A package is missing when trying to #dnf groupinstall 'Basic Desktop'

How reproducible:
Every time

Steps to Reproduce:
1.Install Fedora 25 rawhide from Fedora-Everything-netinst-x86_64-Rawhide-20160520.n.0,iso - Minimal Install
2.#dnf -y update
3.#dnf groupinstall 'Basic Desktop'

Actual results:
No package xorg-x11-drv-freedreno available.
Error: Unable to find a mandatory group package.

Expected results:
Install 'Basic Desktop' group successfully

Additional info:
When trying to groupinstall 'Mate Desktop' or 'Xfce Desktop' or 'Basic Desktop' or 'Fedora Workstation', I also get several other packages missing

xorg-x11-drv-modesetting
xorg-x11-drv-mga
xorg-x11-drv-armsoc
xorg-x11-drv-omap
Comment 1 Rob Clark 2016-05-25 14:29:28 EDT
jfwiw, these days I think -modesetting ddx (which uses glamor/gl to accel 2d) is probably preferred to using -freedreno ddx.
Comment 2 Nicolas Chauvet (kwizart) 2016-05-25 14:37:24 EDT
I expect thoses are deprecated and should be removed from the comps.xml:
xorg-x11-drv-modesetting
xorg-x11-drv-mga

The others are specific for ARM architecture, as you are on x86_64 theses errors should be turned as Warnings instead. Care to re-assign to dnf ?
Comment 3 dsavov 2016-05-25 14:42:40 EDT
(In reply to Nicolas Chauvet (kwizart) from comment #2)
> I expect thoses are deprecated and should be removed from the comps.xml:
> xorg-x11-drv-modesetting
> xorg-x11-drv-mga
> 
> The others are specific for ARM architecture, as you are on x86_64 theses
> errors should be turned as Warnings instead. Care to re-assign to dnf ?

Hello Nicolas
Thanks! I've switched the component to dnf
Comment 4 Parag Nemade 2016-05-26 01:10:18 EDT
I too found this bug. I think this is related to bug 1337731. I have also reported pull-request to update comps for xorg-x11-drv-modesetting.  See https://pagure.io/fedora-comps/pull-request/13

Please note xorg-x11-drv-mga package removal is already committed -> https://pagure.io/fedora-comps/c/c2d7d6e2d3339ee2251b004965ea99fffaaebf27
Comment 5 Rex Dieter 2016-05-26 08:07:40 EDT
*** Bug 1340059 has been marked as a duplicate of this bug. ***
Comment 6 Rex Dieter 2016-05-26 08:08:50 EDT
See linked bug #1340059 , seems to affect (some?) f23 users too.
Comment 7 Kevin Fenzi 2016-05-26 09:04:28 EDT
This looks like another aspect of/the same issue at the proposed f24 blocking https://bugzilla.redhat.com/show_bug.cgi?id=1337731 ? (ie, behavior change in dnf 1.1.9)
Comment 8 Parag Nemade 2016-05-26 09:17:37 EDT
Also reported PR for f22 and f23 comps, see https://pagure.io/fedora-comps/pull-request/15
Comment 9 Rex Dieter 2016-05-26 10:26:06 EDT
See comment #7 , yep appears to be at least part of it , adding that as a dependency for tracking purposes.
Comment 10 Mike 2016-05-28 05:17:31 EDT
The same error occurs during a groupinstall of Haskell - see below; the problem has appeared for F23 x86_64 in the last couple of weeks, since I installed the Haskell group on my desktop (same F23, repos, kernel release, etc) with no problems.
Mike
---
[tommo@aspire ~]$ dnf groupinfo Haskell
Fedora 23 - x86_64 - Updates                    1.3 MB/s |  22 MB     00:17    
Adobe Systems Incorporated                       12 kB/s | 1.8 kB     00:00    
RPM Fusion for Fedora 23 - Free - Test Updates  905 kB/s | 333 kB     00:00    
RPM Fusion for Fedora 23 - Nonfree - Test Updat 432 kB/s | 104 kB     00:00    

Group: Haskell
 Description: Support for developing programs in the Haskell programming language.
 Mandatory Packages:
   cabal-dev
   cabal-rpm
   darcs
   ghc
   ghc-rpm-macros
   haskell-platform
   hlint
   hscolour
 Optional Packages:
   leksah
 Conditional Packages:
   emacs-haskell-mode
[tommo@aspire ~]$ sudo dnf groupinstall Haskell
[sudo] password for tommo: 
Last metadata expiration check: 1:17:34 ago on Sat May 28 08:26:46 2016.
No package cabal-dev available.
Error: Unable to find a mandatory group package.
Comment 11 Mike Goodwin 2016-05-28 18:29:08 EDT
Immediate workaround for this until the missing dependency issues are fixed is to use 

`dnf --setopt=strict=false group install <group>` 

This worked for my case, which was kde-desktop-environment.
Comment 12 Igor Gnatenko 2016-06-06 05:46:38 EDT
*** Bug 1342889 has been marked as a duplicate of this bug. ***
Comment 13 Igor Gnatenko 2016-06-06 05:48:09 EDT
We reverted patch about strict groups, so this bug has been fixed. But let's keep it open to track progress about proper handling such situations.
Comment 14 Stephen Gallagher 2016-07-20 11:25:53 EDT
What specifically still needs to be tracked here? This is assigned to comps, but if it's a general policy thing, that should probably go to an FPC ticket.
Comment 15 Igor Gnatenko 2016-07-20 11:30:31 EDT
(In reply to Stephen Gallagher from comment #14)
> What specifically still needs to be tracked here? This is assigned to comps,
> but if it's a general policy thing, that should probably go to an FPC ticket.
Well, in DNF 2.0 packages which are not found in repo, but present in comps will raise error.

If we are going to stick with comps, we should consider adding new tag about architecture. If we are going proper way - replacing comps with normal RPM packages, then we need slowly migrate current comps into such packages.
Comment 16 Stephen Gallagher 2016-07-20 11:36:27 EDT
(In reply to Igor Gnatenko from comment #15)
> (In reply to Stephen Gallagher from comment #14)
> > What specifically still needs to be tracked here? This is assigned to comps,
> > but if it's a general policy thing, that should probably go to an FPC ticket.
> Well, in DNF 2.0 packages which are not found in repo, but present in comps
> will raise error.
> 
> If we are going to stick with comps, we should consider adding new tag about
> architecture. If we are going proper way - replacing comps with normal RPM
> packages, then we need slowly migrate current comps into such packages.

Could you please open a new bug with that information as the primary description? I think continuing in this bug will be confusing. Just mark the new one as depending on this one.
Comment 17 Kevin Fenzi 2016-07-20 12:07:04 EDT
Actually, could you perhaps open a discussion on say the devel list about this? 

bugs are horrible for discussing design and such. Once we have a plan, then we can file bugs to do those things, but we need a plan first.
Comment 18 Igor Gnatenko 2016-07-21 11:07:26 EDT
(In reply to Kevin Fenzi from comment #17)
> Actually, could you perhaps open a discussion on say the devel list about
> this? 
will do.

Note You need to log in before you can comment on or make changes to this bug.