Bug 133982 - glibc-2.3.3-59 breaks ypbind, ypserv
Summary: glibc-2.3.3-59 breaks ypbind, ypserv
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 134013 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-28 20:20 UTC by Thomas J. Baker
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version: 2.3.3.-61
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 10:14:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas J. Baker 2004-09-28 20:20:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040928
Firefox/0.10

Description of problem:
updated to rawhide, rebooted, ypbind and ypserv no longer work:

[tjb@katratzi tjb]$ /sbin/ypbind -debug
parsing config file
Trying entry: domain rcc broadcast
parsed domain 'rcc' broadcast
add_server() domain: rcc, broadcast
[Welcome to ypbind-mt, version 1.17.2]

get_myaddress: getifaddrs: Success
[tjb@katratzi tjb]$

Similar error with ypserv although I can't debug more on the server as I
needed it running.

Downgrading glibc fixes the problem.

Version-Release number of selected component (if applicable):
glibc-2.3.3-59

How reproducible:
Always

Steps to Reproduce:
1. update to glibc-2.3.3-59
2. reboot
3.
    

Actual Results:  ypbind and ypserv don't work anymore

Additional info:

happens on three systems. two clients and one server.

Comment 1 G.Wolfe Woodbury 2004-09-28 20:29:21 UTC
confirming on a fresh install of 2004-09-28 rawhide.
NFS statd is also buggered.

Comment 2 Ulrich Drepper 2004-09-28 22:11:25 UTC
Yep, this is a typo in a recent glibc change.  == instead of !=. 
Fixed in current CVS, will be in the next RPM (-60 most likely).

Comment 3 Ulrich Drepper 2004-09-29 00:29:41 UTC
*** Bug 134013 has been marked as a duplicate of this bug. ***

Comment 4 Phil Anderson 2004-09-29 13:42:55 UTC
I assume this is the same bug which has screwed up ypbind?

Comment 5 Phil Anderson 2004-09-29 13:47:16 UTC
Oops... ignore that last comment.  I read bug 134013 which only
refered to NFS and not ypbind.

Comment 6 Ulrich Drepper 2004-09-30 10:14:09 UTC
Fixed in 2.3.3-61.  Test it when it becomes publically available and
if necessary reopen.


Note You need to log in before you can comment on or make changes to this bug.