Bug 134013 - glibc-2.3.3-59 breaks NFS mountd & statd
glibc-2.3.3-59 breaks NFS mountd & statd
Status: CLOSED DUPLICATE of bug 133982
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-28 19:12 EDT by Felipe Alfaro Solana
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of "strace rpc.mountd" (81.44 KB, text/plain)
2004-09-28 19:13 EDT, Felipe Alfaro Solana
no flags Details

  None (edit)
Description Felipe Alfaro Solana 2004-09-28 19:12:33 EDT
Description of problem:
Since upgrading to glibc-2.3.3-59, rpc.mountd and rpc.statd are unable
to start. Downgrading to glibc-2.3.3-55 fixes the problem.
Please, look at the attached "strace_rpc_mountd": it's the output
generated by "strace rpc.mountd".

Version-Release number of selected component (if applicable):
glibc-2.3.3-59
nfs-utils-1.0.6-34

How reproducible:
Always (even with SELinux support disabled)

Steps to Reproduce:
1. Upgrade to glibc-2.3.3-59
2. "/etc/init.d/nfslock start" will fail
3. "/etc/init.d/nfs start" will fail
  
Actual results:
Both rpc.mountd and rpc.statd fail to start. It seems a socket-related
problem, although I can't tell for sure.

Expected results:
Both rpc.mountd and rpc.statd should work. NFS is a important
component for many customers.

Additional info:
I have attached the output of "strace rpc.mountd" for further analysis.
Comment 1 Felipe Alfaro Solana 2004-09-28 19:13:17 EDT
Created attachment 104465 [details]
Output of "strace rpc.mountd"
Comment 2 Ulrich Drepper 2004-09-28 20:29:28 EDT

*** This bug has been marked as a duplicate of 133982 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:05:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.