Bug 1339870 - /usr/bin/rados depends on libradosstriper.so.1
Summary: /usr/bin/rados depends on libradosstriper.so.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.0
Assignee: Samuel Just
QA Contact: Rachana Patel
URL:
Whiteboard:
Depends On:
Blocks: 1343229
TreeView+ depends on / blocked
 
Reported: 2016-05-26 03:29 UTC by Ken Dreyer (Red Hat)
Modified: 2017-07-30 15:07 UTC (History)
11 users (show)

Fixed In Version: RHEL: ceph-10.2.2-2.el7cp Ubuntu: ceph_10.2.2-3redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:39:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 16097 0 None None None 2016-06-01 04:33:16 UTC
Red Hat Bugzilla 1212208 0 unspecified CLOSED ship libradosstriper in 1.3 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 1350638 0 unspecified CLOSED [RADOS]:[UPGRADE]: Apparent data loss after upgrading from 1.3.2 to 2.0 using "setuser match path" config 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHBA-2016:1755 0 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Internal Links: 1212208 1345789 1350638

Description Ken Dreyer (Red Hat) 2016-05-26 03:29:00 UTC
Description of problem:
/usr/bin/rados depends on libradosstriper.so.1, and we do not want to ship libradosstriper in RHCS.

Version-Release number of selected component (if applicable):
ceph-common-10.2.1-8.el7cp

How reproducible:
always

Steps to Reproduce:
yum install ceph-common

Actual results:
yum installs libradosstriper1

Expected results:
yum should not install libradosstriper1

Comment 1 Ken Dreyer (Red Hat) 2016-05-26 04:38:59 UTC
Looks like  $(LIBRADOSSTRIPER) was added to rados_LDADD in https://github.com/ceph/ceph/commit/49ab5bb3c436fbe069327859c76b351c4fe06043

I don't know whether we would want to back that patch out downstream (if that's feasible?), or whether we should just ship libradosstriper in the product.

Neil, what is your opinion?

Comment 2 Samuel Just 2016-05-26 14:52:50 UTC
It's there to support some additional options to the rados command for manipulating striped objects, came from the community.

Comment 3 Ken Dreyer (Red Hat) 2016-05-26 14:56:02 UTC
Sam, how easy/hard would it be to back out this change in jewel?

Comment 4 Neil Levine 2016-05-26 15:56:38 UTC
Kne, I am not clear on why you don't want to ship this library?

Comment 5 Ken Dreyer (Red Hat) 2016-05-26 16:09:50 UTC
In RHCS 1.3 we made the decision to not ship it: bz 1212208

Comment 6 Neil Levine 2016-05-26 16:19:19 UTC
The comments on 1212208 seem to indicate there were some concerns about the test coverage of the package, and hence stability & maintainability. 

Sam: are you willing to vouch and maintain the code?

Comment 7 Ken Dreyer (Red Hat) 2016-05-26 18:56:17 UTC
Discussed in the scrub call today with Neil and Sam. Sam will patch this out upstream, and in the meantime we will ship libradosstriper in order to satisfy the package dependency for betas of RHCS 2. But we need to patch this out before GA.

Comment 9 Samuel Just 2016-06-02 20:42:44 UTC
Just pushed wip-bz1341859 to rhgerrit.  I'm not sure how to verify that the packages build.

Comment 10 Samuel Just 2016-06-03 21:58:45 UTC
In rhgerrit as wip-bz1339870 (sorry, I had the bz number wrong in the previous message).

Comment 13 Samuel Just 2016-06-14 18:03:54 UTC
*** Bug 1345789 has been marked as a duplicate of this bug. ***

Comment 21 errata-xmlrpc 2016-08-23 19:39:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html


Note You need to log in before you can comment on or make changes to this bug.