Bug 133988 - Disk Druid fails using existing LVM VG
Disk Druid fails using existing LVM VG
Status: CLOSED DUPLICATE of bug 132217
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-28 16:42 EDT by Matthew Booth
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda stack trace after clicking edit on a precreated LV (73.99 KB, text/plain)
2004-09-28 16:43 EDT, Matthew Booth
no flags Details

  None (edit)
Description Matthew Booth 2004-09-28 16:42:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
Disk Druid fails when trying to reuse an existing volume group in 2
ways. Firstly after choosing Disk Druid, although the VG and all its
LVs are displayed in the tree widget, clicking on the LVM button gives
an error that at least 1 PV must be created first.

To circumvent this, I precreated an LV for my new root partition.
After choosing Disk Druid, I select my newly created LV in the tree
widget and click the edit button to assign it as the root partition.
Anaconda gives a stack trace and exits. (Will attach below)

I have tried the above using both LVM1 and LVM2 metadata with the same
results.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start installing RHEL4 Beta 1 on a machine with an existing volume
group.
2. Choose to partition using Disk Druid

A1: Click LVM

B1: Select an existing logical volume
B2: Click edit
    

Actual Results:
A: Warning is presented that a PV must be created first.
B: Anaconda fails with a stack trace.

Expected Results:
A: User is allowed to modify volume group.
B: User is allowed to edit properties of logical volume.

Additional info:
Comment 1 Matthew Booth 2004-09-28 16:43:36 EDT
Created attachment 104462 [details]
Anaconda stack trace after clicking edit on a precreated LV
Comment 2 Jeremy Katz 2004-09-28 17:10:36 EDT

*** This bug has been marked as a duplicate of 132217 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:05:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.