Bug 132217 (IT_53056) - crash editing existing LVM volume (gtk.Label has no attribute get_active_value)
Summary: crash editing existing LVM volume (gtk.Label has no attribute get_active_value)
Status: CLOSED RAWHIDE
Alias: IT_53056
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
: 132347 132993 133311 133417 133988 134366 137163 137463 (view as bug list)
Depends On:
Blocks: FC3Blocker FC3BugWeekQA
TreeView+ depends on / blocked
 
Reported: 2004-09-09 22:11 UTC by Colin Walters
Modified: 2007-11-30 22:10 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-02 19:59:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Colin Walters 2004-09-09 22:11:56 UTC
Description of problem:

Traceback (most recent call last):
  File
"/usr/src/build/449830-i386/install//usr/lib/anaconda/iw/partition_gui.py",
line 1040, in editCb
    self.editLVMVolumeGroup(vgrequest)
  File
"/usr/src/build/449830-i386/install//usr/lib/anaconda/iw/partition_gui.py",
line 1120, in editLVMVolumeGroup
    origvgrequest, isNew)
  File
"/usr/src/build/449830-i386/install//usr/lib/anaconda/iw/lvm_dialog_gui.py",
line 985, in __init__
    (self.lvmlist, sw) =
self.createAllowedLvmPartitionsList(self.availlvmparts,
self.origvgrequest.physicalVolumes, self.partitions,
origvgrequest.getPreExisting())
  File
"/usr/src/build/449830-i386/install//usr/lib/anaconda/iw/lvm_dialog_gui.py",
line 314, in createAllowedLvmPartitionsList
    pesize = int(self.peCombo.get_active_value())
AttributeError: 'gtk.Label' object has no attribute 'get_active_value'

Comment 1 Colin Walters 2004-09-09 22:12:56 UTC
This is when i try to edit an existing LVM physical volume, by the way.

Comment 2 Jeremy Katz 2004-09-13 15:23:17 UTC
*** Bug 132347 has been marked as a duplicate of this bug. ***

Comment 3 Jeremy Katz 2004-09-15 22:07:42 UTC
Fixed in CVS

Comment 4 Colin Walters 2004-09-16 00:25:19 UTC
Cool, thanks a lot Jeremy.

Comment 5 Colin Walters 2004-09-20 19:32:02 UTC
*** Bug 132993 has been marked as a duplicate of this bug. ***

Comment 6 Jeremy Katz 2004-09-23 02:30:01 UTC
*** Bug 133311 has been marked as a duplicate of this bug. ***

Comment 7 Noa Resare 2004-09-23 08:57:11 UTC
This problem is still reproducible with the installer on the fc2test3
cdr isos.

Comment 8 Andreas Müller 2004-09-23 15:26:19 UTC
I think the problem is in fc3test2... This is because the fixed
anaconda was built after the release of fc3test2. Is there a way to
get a fixed iso (perhaps one I can build myself) or do I have to wait
until fc3test3 is released?

Comment 9 Jeremy Katz 2004-09-23 20:48:15 UTC
*** Bug 133417 has been marked as a duplicate of this bug. ***

Comment 10 Jeremy Katz 2004-09-28 21:10:49 UTC
*** Bug 133988 has been marked as a duplicate of this bug. ***

Comment 11 Jef Spaleta 2004-09-29 01:14:40 UTC
Re: Comment #8
the development tree.. should have a boot.iso available, with which
you can start an install of the development tree itself, and that
boot.iso should use the newest available development anaconda for you
to confirm this issue is fixed.

-jef

Comment 12 Jeremy Katz 2004-10-01 18:45:31 UTC
*** Bug 134366 has been marked as a duplicate of this bug. ***

Comment 13 Alexandre Oliva 2004-10-02 19:59:48 UTC
Fixed in re1001.0.

Comment 14 Jeremy Katz 2004-10-26 13:16:44 UTC
*** Bug 137163 has been marked as a duplicate of this bug. ***

Comment 15 Jeremy Katz 2004-10-28 17:26:00 UTC
*** Bug 137463 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.