Bug 1339943 - User admin already logged in
Summary: User admin already logged in
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: core
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Nishanth Thomas
QA Contact: sds-qe-bugs
URL:
Whiteboard:
: 1351326 (view as bug list)
Depends On:
Blocks: Console-2-Feature-Freeze Console-2-DevFreeze
TreeView+ depends on / blocked
 
Reported: 2016-05-26 09:00 UTC by Chris Blum
Modified: 2016-08-23 19:52 UTC (History)
3 users (show)

Fixed In Version: rhscon-core-0.0.26-1.el7scon.x86_64
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:52:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Chris Blum 2016-05-26 09:00:41 UTC
Description of problem:
When using the RHS-C I sometimes get logged out on page refresh. I immediately get redirected to the login page, but logging in as admin fails.
The log of skyring shows:
May 26 04:55:16 rhs-c skyring[23312]: 2016-05-26T04:55:16.41-04:00 INFO     auth.go:138 Login] User: admin already logged in

IMO we should always allow the admin user to login, even if there already is one session. At least there should be a message explaining why the login fails

Version-Release number of selected component (if applicable):
Latest current release

How reproducible:
Every now and then, still need to investigate what triggers me being logged out on page refresh...

Steps to Reproduce:
1. Use the Web UI, get logged out on pressing F5
2. Try to log back in --> fails
3. Look at skyring log for matching log entry

Actual results:
Login fails until logged in sessions times out or skyring restart

Expected results:
Login should always work as admin or I should be informed why I cannot login on the web page

Additional info:

Comment 2 Nishanth Thomas 2016-06-20 16:23:30 UTC
I am not seeing this issue with latest builds. I think the root cause was the number mongodb connection reaching the maximum, which fixed now. Please re-open if found again

Comment 3 Martin Kudlej 2016-07-01 12:06:35 UTC
I haven't seen this issue for long time. -> VERIFIED

Comment 4 Jeff Applewhite 2016-07-05 20:38:50 UTC
does logging in as a different user still prevent logins by admin?

Comment 5 Chris Blum 2016-07-07 08:34:21 UTC
I think that this has been resolved with one of the updates... Still not sure why I saw it thought :/
IMO we can close this Bug.

Comment 6 Nishanth Thomas 2016-07-11 10:53:30 UTC
*** Bug 1351326 has been marked as a duplicate of this bug. ***

Comment 8 errata-xmlrpc 2016-08-23 19:52:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.