Bug 134002 - SCSI problems with 256 byte sector devices
Summary: SCSI problems with 256 byte sector devices
Status: CLOSED DUPLICATE of bug 134001
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-28 21:42 UTC by Alan Cox
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:05:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alan Cox 2004-09-28 21:42:33 UTC
A SCSI device with 256 byte sectors seems to give the kernel
heartache. Unfortunately this includes some low size smartmedia type
devices.

Sep 28 20:05:42 localhost kernel: scsi4 : SCSI emulation for USB Mass
Storage devices
Sep 28 20:05:42 localhost kernel:   Vendor: Sandisk   Model: ImageMate
SDDR09  Rev: 0100
Sep 28 20:05:42 localhost kernel:   Type:   Direct-Access            
         ANSI SCSI revision: 02
Sep 28 20:05:51 localhost kernel: sddr09: Found Flash card, ID = 98 EA
00 00: Manuf. Toshiba, 2 MB
Sep 28 20:05:51 localhost kernel: SCSI device sdd: 8160 256-byte hdwr
sectors (2 MB)
Sep 28 20:05:51 localhost kernel: sdd: test WP failed, assume Write
Enabled
Sep 28 20:05:51 localhost kernel: sdd: assuming drive cache: write through
Sep 28 20:05:51 localhost kernel:  sdd:SCSI error : <4 0 0 0> return
code = 0x10070000
Sep 28 20:05:51 localhost kernel: end_request: I/O error, dev sdd,
sector 0
Sep 28 20:05:51 localhost kernel: Buffer I/O error on device sdd,
logical block 0
Sep 28 20:05:51 localhost kernel: SCSI error : <4 0 0 0> return code =
0x10070000
Sep 28 20:05:51 localhost kernel: end_request: I/O error, dev sdd,
sector 0
Sep 28 20:05:51 localhost kernel: Buffer I/O error on device sdd,
logical block 0
Sep 28 20:05:51 localhost kernel: SCSI error : <4 0 0 0> return code =
0x10070000
Sep 28 20:05:51 localhost kernel: end_request: I/O error, dev sdd,
sector 4072
Sep 28 20:05:51 localhost kernel: Buffer I/O error on device sdd,
logical block 509Sep 28 20:05:51 localhost kernel: SCSI error : <4 0 0
0> return code = 0x10070000
Sep 28 20:05:51 localhost kernel: end_request: I/O error, dev sdd,
sector 4072
Sep 28 20:05:51 localhost kernel: Buffer I/O error on device sdd,
logical block 509Sep 28 20:05:52 localhost kernel: SCSI error : <4 0 0
0> return code = 0x10070000
Sep 28 20:05:52 localhost kernel: end_request: I/O error, dev sdd,
sector 0
Sep 28 20:05:52 localhost kernel: Buffer I/O error on device sdd,
logical block 0
Sep 28 20:05:52 localhost kernel:  unable to read partition table
Sep 28 20:05:52 localhost kernel: Attached scsi removable disk sdd at
scsi4, channel 0, id 0, lun 0

Attempting to mount the device then hangs. Removing the USB dongle reports
Sep 28 20:06:01 localhost kernel: usb-storage: Error in device_reset:
invalid state 256

and it all stays broken

Comment 1 Bill Nottingham 2004-09-29 05:04:17 UTC

*** This bug has been marked as a duplicate of 134001 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:05:59 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.