Bug 1340196 - (not)click-able charts and statuses
Summary: (not)click-able charts and statuses
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 2
Assignee: kamlesh
QA Contact: Lubos Trilety
URL:
Whiteboard:
: 1346314 (view as bug list)
Depends On: 1347816
Blocks: Console-2-DevFreeze
TreeView+ depends on / blocked
 
Reported: 2016-05-26 17:00 UTC by Lubos Trilety
Modified: 2016-08-23 19:52 UTC (History)
4 users (show)

Fixed In Version: rhscon-ui-0.0.40-1.el7scon.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:52:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 0 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Lubos Trilety 2016-05-26 17:00:30 UTC
Description of problem:
All donut charts seems to be click-able, which does not make sense.
cpu usage
memory usage
pool usage
cluster usage
etc.
OK statuses of items seems to be click-able too on dashboard page, but nothing happens when it's clicked on them.

Version-Release number of selected component (if applicable):
rhscon-core-0.0.19-1.el7scon.x86_64
rhscon-ceph-0.0.18-1.el7scon.x86_64
rhscon-ui-0.0.34-1.el7scon.noarch

How reproducible:
100%

Steps to Reproduce:
1. Look on any donut chart, e.g. cpu usage
2. On dashboard look on any status which is OK
3.

Actual results:
A chart and status seems to be click-able, but nothing happens when it's clicked on it

Expected results:
Chart and statuses should not look like click-able

Additional info:

Comment 1 Nishanth Thomas 2016-06-16 05:05:36 UTC
Need to remove all the 'click-ables' which doesn't make sense across all dsashboards

Comment 2 Nishanth Thomas 2016-06-16 05:06:22 UTC
*** Bug 1346314 has been marked as a duplicate of this bug. ***

Comment 3 Lubos Trilety 2016-07-22 10:55:19 UTC
Tested on:
rhscon-core-0.0.34-1.el7scon.x86_64
rhscon-ui-0.0.48-1.el7scon.noarch
rhscon-core-selinux-0.0.34-1.el7scon.noarch
rhscon-ceph-0.0.33-1.el7scon.x86_64

Comment 5 errata-xmlrpc 2016-08-23 19:52:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.