Bug 134023 - Evolution crashes when switching components
Evolution crashes when switching components
Status: CLOSED DUPLICATE of bug 133969
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks: 131589
  Show dependency treegraph
 
Reported: 2004-09-28 21:13 EDT by Ivan Gyurdiev
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2004-09-28 21:13:42 EDT
Evolution crashes starting today (Sept 28).
I track rawhide, it worked fine yesterday.
I have evolution-2.0.0-2.

It crashes when I change components, but does not crash
if I open particular components with component= on the cmdline.

Here's a trace - I don't know how helpful it will be:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208109312 (LWP 15362)]
0x0038ea4d in g_type_check_instance_is_a () from
/usr/lib/libgobject-2.0.so.0
(gdb) info stack
#0  0x0038ea4d in g_type_check_instance_is_a ()
   from /usr/lib/libgobject-2.0.so.0
#1  0x00374a73 in g_object_get_qdata () from /usr/lib/libgobject-2.0.so.0
#2  0x011c9c93 in gtk_widget_set_state () from
/usr/lib/libgtk-x11-2.0.so.0
#3  0x011ca862 in gtk_widget_set_uposition () from
/usr/lib/libgtk-x11-2.0.so.0
#4  0x0117ce4b in gtk_tool_item_get_type () from
/usr/lib/libgtk-x11-2.0.so.0
#5  0x0117ba02 in gtk_tool_button_get_type () from
/usr/lib/libgtk-x11-2.0.so.0
#6  0x00fa8895 in bonobo_ui_toolbar_control_item_get_type ()
   from /usr/lib/libbonoboui-2.so.0
#7  0x003708dc in g_object_unref () from /usr/lib/libgobject-2.0.so.0
#8  0x011cc3f5 in gtk_widget_unref () from /usr/lib/libgtk-x11-2.0.so.0
#9  0x00f99118 in bonobo_ui_container_get_engine ()
   from /usr/lib/libbonoboui-2.so.0
#10 0x00f9d7a3 in bonobo_ui_engine_object_set ()
   from /usr/lib/libbonoboui-2.so.0
#11 0x00f9882d in bonobo_ui_container_get_type ()
   from /usr/lib/libbonoboui-2.so.0
#12 0x05543815 in _ORBIT_skel_small_Bonobo_UIContainer_setObject ()
   from /usr/lib/libbonobo-2.so.0
#13 0x0031146d in ORBit_c_stub_invoke () from /usr/lib/libORBit-2.so.0
#14 0x05547a79 in Bonobo_UIContainer_setObject ()
   from /usr/lib/libbonobo-2.so.0
#15 0x00f9648d in bonobo_ui_component_object_set ()
---Type <return> to continue, or q <return> to quit---
   from /usr/lib/libbonoboui-2.so.0
#16 0x05900651 in e_user_creatable_items_handler_activate ()
   from /usr/lib/evolution/2.0/libeshell.so.0
#17 0x0430aede in calendar_control_deactivate ()
   from /usr/lib/evolution/2.0/components/libevolution-calendar.so
#18 0x00386166 in g_cclosure_marshal_VOID__BOOLEAN ()
   from /usr/lib/libgobject-2.0.so.0
#19 0x0036e347 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#20 0x0038394e in g_signal_has_handler_pending ()

   from /usr/lib/libgobject-2.0.so.0
#21 0x003859bc in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#22 0x00385c5a in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#23 0x00f8d8ed in bonobo_control_get_remote_ui_container ()
   from /usr/lib/libbonoboui-2.so.0
#24 0x05543e2e in _ORBIT_skel_small_Bonobo_Control_activate ()
   from /usr/lib/libbonobo-2.so.0
#25 0x0031146d in ORBit_c_stub_invoke () from /usr/lib/libORBit-2.so.0
#26 0x05549157 in Bonobo_Control_activate () from
/usr/lib/libbonobo-2.so.0
#27 0x00f8b2ca in bonobo_control_frame_control_activate ()
   from /usr/lib/libbonoboui-2.so.0
#28 0x0805d83a in e_shell_window_commands_setup ()
#29 0x0805e08d in e_shell_window_commands_setup ()
#30 0x00386393 in g_cclosure_marshal_VOID () from
/usr/lib/libgobject-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#31 0x0036e347 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#32 0x0038394e in g_signal_has_handler_pending ()
   from /usr/lib/libgobject-2.0.so.0
#33 0x003859bc in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#34 0x00385c5a in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#35 0x0806249b in e_shell_new ()
#36 0x003860ae in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#37 0x0036e347 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#38 0x0038394e in g_signal_has_handler_pending ()
   from /usr/lib/libgobject-2.0.so.0
#39 0x003859bc in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#40 0x00385c5a in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#41 0x01173565 in gtk_toggle_button_toggled ()
   from /usr/lib/libgtk-x11-2.0.so.0
#42 0x0117399b in gtk_toggle_button_set_inconsistent ()
   from /usr/lib/libgtk-x11-2.0.so.0
#43 0x003860ae in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#44 0x0036e6b2 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#45 0x0036e347 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#46 0x00383616 in g_signal_has_handler_pending ()
   from /usr/lib/libgobject-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#47 0x003859bc in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#48 0x00385c5a in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#49 0x0101a2a4 in gtk_button_clicked () from /usr/lib/libgtk-x11-2.0.so.0
#50 0x01173a02 in gtk_toggle_button_set_inconsistent ()
   from /usr/lib/libgtk-x11-2.0.so.0
#51 0x003860ae in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#52 0x0036e6b2 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#53 0x0036e347 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#54 0x00383616 in g_signal_has_handler_pending ()
   from /usr/lib/libgobject-2.0.so.0
#55 0x003859bc in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#56 0x00385c5a in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#57 0x0101a1ec in gtk_button_released () from /usr/lib/libgtk-x11-2.0.so.0
#58 0x0101b297 in gtk_button_set_relief () from
/usr/lib/libgtk-x11-2.0.so.0
#59 0x010d1d77 in gtk_marshal_VOID__UINT_STRING ()
   from /usr/lib/libgtk-x11-2.0.so.0
#60 0x0036e6b2 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#61 0x0036e347 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#62 0x00384576 in g_signal_has_handler_pending ()
   from /usr/lib/libgobject-2.0.so.0
#63 0x00385613 in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#64 0x00385c5a in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#65 0x011c5855 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#66 0x010d003b in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#67 0x010d0340 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#68 0x00a00092 in gdk_event_get_graphics_expose ()
   from /usr/lib/libgdk-x11-2.0.so.0
#69 0x003c44fb in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#70 0x003c5f82 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#71 0x003c622f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#72 0x0552edd5 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#73 0x08063a69 in main ()
Comment 1 Matthias Clasen 2004-09-29 10:18:25 EDT

*** This bug has been marked as a duplicate of 133969 ***
Comment 2 Matthias Clasen 2004-09-29 10:24:58 EDT
Thanks for the bug report. This particular bug has already been reported
into our bug tracking system, but please feel free to report any further
bugs you find.
Comment 3 Red Hat Bugzilla 2006-02-21 14:06:00 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.