Bug 133969 - Reconfiguring toolbar buttons crashes Evolution
Reconfiguring toolbar buttons crashes Evolution
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libbonoboui (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
: 133979 134023 134050 134079 134126 134219 (view as bug list)
Depends On:
Blocks: 131589
  Show dependency treegraph
 
Reported: 2004-09-28 14:45 EDT by Herbert Rutledge
Modified: 2013-04-02 00:20 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 16:17:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Herbert Rutledge 2004-09-28 14:45:37 EDT
Description of problem:
libbonoboui from Rawhide displays extra large toolbar buttons in
Evolution and crashes Evolution Contacts, Calendar and Tasks when selected

Version-Release number of selected component (if applicable):
libbonoboui--2.8.0.99cvs20040927-1

How reproducible:
Always

Steps to Reproduce:
1.  Start Evolution
2.  Notice larger toolbar buttons
3.  Select Contacts, Calendars or Tasks
4.  Evolution crashes
  
Actual results:
1.  Toolbar buttons are so large that not all of them can be
    displayed on the toolbar
2.  Selecting Contacts, Calendars or Tasks crashes Evolution

Expected results:
1.  Toolbar buttons the same size as before
2.  Contacts, Calendars and Tasks can be selected without crashing
    Evolution

Additional info:
Messages after starting Evolution from the command line:

asked to activate component_id
`OAFIID:GNOME_Evolution_Addressbook_Component:2.0'
asked to activate component_id
`OAFIID:GNOME_Evolution_Addressbook_Component:2.0'
asked to activate component_id
`OAFIID:GNOME_Evolution_Addressbook_Component:2.0'
in e_book_response_open

(evolution:8202): Bonobo-WARNING **: Non-toolbar parent '<NULL-instance>'

(evolution:8202): Bonobo-CRITICAL **: file
bonobo-ui-toolbar-control-item.c: line 107
(impl_toolbar_reconfigured): assertion `toolbar != NULL' failed
Comment 1 sangu 2004-09-29 00:35:34 EDT
Backtrace was generated from '/usr/bin/evolution-2.0'

(no debugging symbols found)...Using host libthread_db library
"/lib/tls/libthread_db.so.1".
(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...[Thread debugging using libthread_db enabled]
[New Thread -171817216 (LWP 4747)]
[New Thread -243983440 (LWP 4796)]
[Thread debugging using libthread_db enabled]
[New Thread -171817216 (LWP 4747)]
[New Thread -243983440 (LWP 4796)]
[Thread debugging using libthread_db enabled]
[New Thread -171817216 (LWP 4747)]
[New Thread -243983440 (LWP 4796)]
[New Thread -232948816 (LWP 4795)]
[New Thread -220656720 (LWP 4764)]
[New Thread -210166864 (LWP 4763)]
(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...0xf6fe9782
in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#0  0xf6fe9782 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0xf65033db in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#2  0xf6bf9f50 in libgnomeui_module_info_get () from
/usr/lib/libgnomeui-2.so.0
#3  0x08063750 in e_sidebar_new ()
#4  <signal handler called>
#5  0xf63377d9 in g_datalist_clear () from /usr/lib/libglib-2.0.so.0
#6  0xf63b26a1 in g_object_interface_list_properties () from
/usr/lib/libgobject-2.0.so.0
#7  0xf6722121 in gtk_object_sink () from /usr/lib/libgtk-x11-2.0.so.0
#8  0xf67fe8de in gtk_widget_set_uposition () from
/usr/lib/libgtk-x11-2.0.so.0
#9  0xf67b0e4b in gtk_tool_item_get_type () from
/usr/lib/libgtk-x11-2.0.so.0
#10 0xf67afa02 in gtk_tool_button_get_type () from
/usr/lib/libgtk-x11-2.0.so.0
#11 0xf6b29895 in bonobo_ui_toolbar_control_item_get_type () from
/usr/lib/libbonoboui-2.so.0
#12 0xf63b28dc in g_object_unref () from /usr/lib/libgobject-2.0.so.0
#13 0xf68003f5 in gtk_widget_unref () from /usr/lib/libgtk-x11-2.0.so.0
#14 0xf6b1a118 in bonobo_ui_container_get_engine () from
/usr/lib/libbonoboui-2.so.0
#15 0xf6b1e7a3 in bonobo_ui_engine_object_set () from
/usr/lib/libbonoboui-2.so.0
#16 0xf6b1982d in bonobo_ui_container_get_type () from
/usr/lib/libbonoboui-2.so.0
#17 0xf6aa6815 in _ORBIT_skel_small_Bonobo_UIContainer_setObject ()
from /usr/lib/libbonobo-2.so.0
#18 0xf69aa46d in ORBit_c_stub_invoke () from /usr/lib/libORBit-2.so.0
#19 0xf6aaaa79 in Bonobo_UIContainer_setObject () from
/usr/lib/libbonobo-2.so.0
#20 0xf6b1748d in bonobo_ui_component_object_set () from
/usr/lib/libbonoboui-2.so.0
#21 0xf6fe3651 in e_user_creatable_items_handler_activate () from
/usr/lib/evolution/2.0/libeshell.so.0
#22 0xf581c886 in mail_filter_delete_uri () from
/usr/lib/evolution/2.0/components/libevolution-mail.so
#23 0xf63c8166 in g_cclosure_marshal_VOID__BOOLEAN () from
/usr/lib/libgobject-2.0.so.0
#24 0xf63b0347 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#25 0xf63c594e in g_signal_has_handler_pending () from
/usr/lib/libgobject-2.0.so.0
#26 0xf63c79bc in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#27 0xf63c7c5a in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#28 0xf6b0e8ed in bonobo_control_get_remote_ui_container () from
/usr/lib/libbonoboui-2.so.0
#29 0xf6aa6e2e in _ORBIT_skel_small_Bonobo_Control_activate () from
/usr/lib/libbonobo-2.so.0
#30 0xf69aa46d in ORBit_c_stub_invoke () from /usr/lib/libORBit-2.so.0
#31 0xf6aac157 in Bonobo_Control_activate () from
/usr/lib/libbonobo-2.so.0
#32 0xf6b0c2ca in bonobo_control_frame_control_activate () from
/usr/lib/libbonoboui-2.so.0
#33 0x0805d83a in e_shell_window_commands_setup ()
#34 0x0805e08d in e_shell_window_commands_setup ()
#35 0xf63c8393 in g_cclosure_marshal_VOID () from
/usr/lib/libgobject-2.0.so.0
#36 0xf63b0347 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#37 0xf63c594e in g_signal_has_handler_pending () from
/usr/lib/libgobject-2.0.so.0
#38 0xf63c79bc in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#39 0xf63c7c5a in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#40 0x0806249b in e_shell_new ()
#41 0xf63c80ae in g_cclosure_marshal_VOID__VOID () from
/usr/lib/libgobject-2.0.so.0
#42 0xf63b0347 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#43 0xf63c594e in g_signal_has_handler_pending () from
/usr/lib/libgobject-2.0.so.0
#44 0xf63c79bc in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#45 0xf63c7c5a in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#46 0xf67a7565 in gtk_toggle_button_toggled () from
/usr/lib/libgtk-x11-2.0.so.0
#47 0xf67a799b in gtk_toggle_button_set_inconsistent () from
/usr/lib/libgtk-x11-2.0.so.0
#48 0xf63c80ae in g_cclosure_marshal_VOID__VOID () from
/usr/lib/libgobject-2.0.so.0
#49 0xf63b06b2 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#50 0xf63b0347 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#51 0xf63c5616 in g_signal_has_handler_pending () from
/usr/lib/libgobject-2.0.so.0
#52 0xf63c79bc in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#53 0xf63c7c5a in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#54 0xf664e2a4 in gtk_button_clicked () from /usr/lib/libgtk-x11-2.0.so.0
#55 0xf67a7a02 in gtk_toggle_button_set_inconsistent () from
/usr/lib/libgtk-x11-2.0.so.0
#56 0xf63c80ae in g_cclosure_marshal_VOID__VOID () from
/usr/lib/libgobject-2.0.so.0
#57 0xf63b06b2 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#58 0xf63b0347 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#59 0xf63c5616 in g_signal_has_handler_pending () from
/usr/lib/libgobject-2.0.so.0
#60 0xf63c79bc in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#61 0xf63c7c5a in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#62 0xf664e1ec in gtk_button_released () from /usr/lib/libgtk-x11-2.0.so.0
#63 0xf664f297 in gtk_button_set_relief () from
/usr/lib/libgtk-x11-2.0.so.0
#64 0xf6705d77 in gtk_marshal_VOID__UINT_STRING () from
/usr/lib/libgtk-x11-2.0.so.0
#65 0xf63b06b2 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#66 0xf63b0347 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#67 0xf63c6576 in g_signal_has_handler_pending () from
/usr/lib/libgobject-2.0.so.0
#68 0xf63c7613 in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#69 0xf63c7c5a in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#70 0xf67f9855 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#71 0xf670403b in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#72 0xf6704340 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#73 0xf64b9092 in gdk_event_get_graphics_expose () from
/usr/lib/libgdk-x11-2.0.so.0
#74 0xf63474fb in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#75 0xf6348f82 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#76 0xf634922f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#77 0xf6a91dd5 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#78 0x08063a69 in main ()

Thread 5 (Thread -210166864 (LWP 4763)):
#0  0xf6fe9782 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
No symbol table info available.
#1  0xf62b93c4 in poll () from /lib/tls/libc.so.6
No symbol table info available.
#2  0xf6348f13 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#3  0xf634922f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0xf55cfe5b in e_book_set_default_source () from /usr/lib/libebook.so.8
No symbol table info available.
#5  0xf64fd1c5 in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#6  0xf62c2fea in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 4 (Thread -220656720 (LWP 4764)):
#0  0xf6fe9782 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
No symbol table info available.
#1  0xf62b93c4 in poll () from /lib/tls/libc.so.6
No symbol table info available.
#2  0xf6348f13 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#3  0xf634922f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0xf69afbff in link_thread_io_context () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#5  0xf639e1a4 in ?? () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#6  0xf2d90a98 in ?? ()
No symbol table info available.
#7  0xf63615c2 in g_static_private_free () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
Comment 2 Nicolas Mailhot 2004-09-29 02:47:01 EDT
*** Bug 133979 has been marked as a duplicate of this bug. ***
Comment 3 Matthias Clasen 2004-09-29 10:18:32 EDT
*** Bug 134023 has been marked as a duplicate of this bug. ***
Comment 4 Matthias Clasen 2004-09-29 15:05:32 EDT
libbonoboui-2.8.0.99cvs20040929-1 should fix this.
Comment 5 Bill Nottingham 2004-09-29 17:00:00 EDT
*** Bug 134050 has been marked as a duplicate of this bug. ***
Comment 6 Bill Nottingham 2004-09-29 17:05:39 EDT
*** Bug 134079 has been marked as a duplicate of this bug. ***
Comment 7 Dave Malcolm 2004-09-30 10:38:35 EDT
*** Bug 134126 has been marked as a duplicate of this bug. ***
Comment 8 Jonathan Blandford 2004-09-30 10:50:08 EDT
*** Bug 134219 has been marked as a duplicate of this bug. ***
Comment 9 Tom "spot" Callaway 2004-09-30 13:52:23 EDT
libbonoboui-2.8.0.99cvs20040929-2 resolves this crash, and makes the
icons not bloated. Jonathan, you can close this one as RAWHIDE if you
want.
Comment 10 Jonathan Blandford 2004-09-30 16:17:20 EDT
Cool.

Note You need to log in before you can comment on or make changes to this bug.