This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 134026 - Hang detecting new hardware
Hang detecting new hardware
Status: CLOSED DUPLICATE of bug 135171
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-09-28 21:25 EDT by Alan Cox
Modified: 2015-01-04 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2004-09-28 21:25:57 EDT
Laptop with PCI express, ICH6M SATA, PCI express mobile radeon. This
booted fine with FC2 but hangs detecting new hardware with FC3Test2.
Comment 2 Alan Cox 2004-09-28 22:03:57 EDT
The USB kernel code logs

usb 3-1: control timeout on ep0out
uhci_hcd: 0000:00:1d.1: Unlink after no-IRQ? Different ACPI or APIC
settings may help.

After this it appears catting /proc/bus/usb/devices hangs. This same
situation does not cause a hang on FC2 kernels. Looks like someone
forgot to drop a lock on an error path ? Could this be to do with the
serialization and locking fixes for USB I wonder
Comment 3 Alan Cox 2004-10-15 12:01:39 EDT
Ok this is a kernel bug at heart. Dupped to the kernel bug


*** This bug has been marked as a duplicate of 135171 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:06:00 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.