Bug 135171 - Access to /proc/bus/usb/devices hangs the kernel
Summary: Access to /proc/bus/usb/devices hangs the kernel
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 134026 (view as bug list)
Depends On:
Blocks: FC3Target FC3Blocker
TreeView+ depends on / blocked
 
Reported: 2004-10-09 18:13 UTC by Alan Cox
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-16 21:45:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alan Cox 2004-10-09 18:13:13 UTC
Description of problem:

At any point after a USB timeout occurs (as they tend to do plugging
devices) the 
USB devices file access hang the system deadlocked on a semaphore.
This has horrible consequences

One test setup shows this during boot up so Anaconda hangs and you
cannot install.
A second shows it when the monitor (with USB hub) powers down. After
that anything touching the USB devices file hangs the box. 

Thirdly you can cause it to order as a user by inserting and quickly
removing a device, killing the hal layer and rendering the box
unusable without even having login access to it.


This bug appears to have arrived between 2.6.6 and 2.6.7 somewhere.

Comment 1 Alan Cox 2004-10-09 18:15:16 UTC
This also btw seems to cause some of the kudzu hangs people see.


Comment 2 Bill Nottingham 2004-10-11 14:43:44 UTC
Can you reproduce with .603, or even BK head?

Comment 3 Alan Cox 2004-10-11 14:49:57 UTC
Its present in current 2.6.9-rc snapshots too. Came in between 2.6.6
and 2.6.7 somewhere.


Comment 4 Alan Cox 2004-10-15 15:26:11 UTC
Done some more digging

I cannot reproduce this with 2.6.8.1 vanilla, only various RH builds
so it looks like something that is specific to our tree. WIll test
.603 for completeness


Comment 5 Alan Cox 2004-10-15 16:01:50 UTC
*** Bug 134026 has been marked as a duplicate of this bug. ***

Comment 6 Alan Cox 2004-10-15 16:04:37 UTC
Propogating block from dup

Comment 7 Alan Cox 2004-10-16 21:45:16 UTC
541 has the buggy change -  624 is ok



Note You need to log in before you can comment on or make changes to this bug.