Bug 134031 - rpc.statd error message sent to /dev/null
rpc.statd error message sent to /dev/null
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-28 22:30 EDT by Russell Coker
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-31 16:15:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Russell Coker 2004-09-28 22:30:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, like Gecko)

Description of problem:
When rpc.statd is started on boot it aborts.  Below is part of the strace showing the problem.  I'm not sure why it thinks that the address is already in use or whether that is a bug.  But it's definitely a bug to send an error message to /dev/null.

The following strace output shows that /dev/null is mapped to file handle 2, file handle 2 is duped to 6, and then the error message is written to file handle 6 and NOT TO SYSLOG.

open("/dev/null", O_RDWR)               = 3
close(0)                                = 0
dup2(3, 0)                              = 0
close(1)                                = 0
dup2(3, 1)                              = 1
close(2)                                = 0
dup2(3, 2)                              = 2
[...]
close(6)                                = 0
dup(2)                                  = 6
fcntl64(6, F_GETFL)                     = 0x2 (flags O_RDWR)
fstat64(6, {st_mode=S_IFCHR|0666, st_rdev=makedev(1, 3), ...}) = 0
ioctl(6, SNDCTL_TMR_TIMEBASE or TCGETS, 0xfee4b3b8) = -1 ENOTTY (Inappropriate i
octl for device)
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xf6
fff000
_llseek(6, 0, [0], SEEK_CUR)            = 0
write(6, "get_myaddress: getifaddrs: Address already in use\n", 50) = 50


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
I can reproduce this by starting rpc.statd and having it fail without explaining why.

Additional info:
Comment 1 Bill Nottingham 2004-09-29 01:12:58 EDT
Bug 133982 is probably why it's crashing, FWIW.
Comment 2 Steve Dickson 2005-10-31 16:15:39 EST
Fixed in later release of nfs-utils

Note You need to log in before you can comment on or make changes to this bug.