Bug 134058 - Upgrade offers extra empty choice
Summary: Upgrade offers extra empty choice
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
: 135000 (view as bug list)
Depends On:
Blocks: FC3Target
TreeView+ depends on / blocked
 
Reported: 2004-09-29 10:49 UTC by Matthias Saou
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-30 11:55:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthias Saou 2004-09-29 10:49:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040806 Firefox/0.9.3

Description of problem:
When booting the FC3 test2 DVD, and choosing "Upgrade an existing
installation", the drop-down list offers me my existing Fedora Core 2
installation as the first choice, but there is also an empty line
below it that I can select.
When this empty line is selected and "Next" is clicked, there is a
traceback about "IndexError: list index out of range" (examine_gui.py
line 42, in getNext rootfs = self.parts[self.upgradecombo.get_active()].

Version-Release number of selected component (if applicable):
FC3 test2 DVD

How reproducible:
Always

Steps to Reproduce:
1. Choose to upgrade
2. Select the empty line
3. Crash
    

Actual Results:  Python traceback from anaconda.

Expected Results:  The drop-down menu of current installations
shouldn't display that extra line.

Additional info:

Maybe this is due to labels or my partitions. This is a laptop which
has currently configured an hda1 with LABEL=/ and my Fedora Core 2
system, and an hda2 with LABEL=/data and only data files, no /etc on
it or anything. I can copy/paste my partition table or any extra info
if needed.

Comment 1 Jeremy Katz 2004-09-29 16:56:13 UTC
Fixed in CVS.  Thanks.

Comment 2 Jeremy Katz 2004-10-11 02:29:17 UTC
*** Bug 135000 has been marked as a duplicate of this bug. ***

Comment 3 Matthias Saou 2005-03-30 11:55:57 UTC
Confirmed fixed in FC4Test1 anaconda.


Note You need to log in before you can comment on or make changes to this bug.