Bug 135000 - Upgrade Examine - too many device targets in lcombobox -> list index exception
Upgrade Examine - too many device targets in lcombobox -> list index exception
Status: CLOSED DUPLICATE of bug 134058
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-07 17:01 EDT by julia
Modified: 2016-07-18 09:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description julia 2004-10-07 17:01:13 EDT
Description of problem:
  At the "Upgrade Examine" step of the FC3t2 installer, after
selecting your locale and such, there is a list box under "Upgrade an
existing installation" "The following installed system will be
upgraded:" that says "/dev/hda5" or something similar. If you drop
down the list box there is a second choice which is blank and if you
select this one and click "> Next" the following happens:

 File "/usr/src/build/451389-i386/install//usr/lib/anaconda/gui.py",
line 785, in nextClicked
   rc = self.currentWindow.getNext ()
 File
"/usr/src/build/451389-i386/install//usr/lib/anaconda/iw/examine_gui.py",
line 42, in getNext
   rootfs = self.parts[self.upgradecombo.get_active()]
IndexError: list index out of range

Version-Release number of selected component (if applicable):

Fedora Core 2.91 Test 2 build 451389-i386 I guess

How reproducible:

 100%

Steps to Reproduce:
1. Boot FC3t2 DVD, skip media test (already tested disk)
2. Select English with a U.S. English keyboard layout (NEXT)
3. Drop down combobox under "The following installed system will be
upgraded:" and select the second blank "" menu item.
4. Click Next
  
Actual results:

   A window titled "Exception Occured" pops up with the above entered
python traceback. Clicking Ok will exit the install.

Expected results:

   There probably shouldn't be a second blank item in the combobox.

Additional info:

   There was only one hard drive in the system, no USB or firewire or
SCSI drives or anything else.
Comment 1 Jeremy Katz 2004-10-10 22:28:59 EDT

*** This bug has been marked as a duplicate of 134058 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:13 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.